1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Turn Signal mystery

Discussion in '2nd Gen 4Runners (1990-1995)' started by chuck, May 8, 2018.

  1. May 8, 2018 at 9:06 PM
    #1
    chuck

    chuck [OP] New Member

    Joined:
    Apr 2, 2018
    Member:
    #5760
    Messages:
    4
    Gender:
    Male
    First Name:
    chuck
    Vehicle:
    1995 4runner
    I have a 95 4runner. Recently it developed a problem with the turn signals. When you turn them on, they stay lit, solid. Indicate right, front, rear and dash lights come on and don't flash. Same with left. When you hit the emergency flasher all the lights come on. I know what you are thinking, Noob, its the flasher silly. Sorry, I have tried 3 different flashers and bench tested the factory one as per the manual. What could it be?
     
  2. May 9, 2018 at 8:20 AM
    #2
    jester243

    jester243 rabble rabble rabble

    Joined:
    Jul 13, 2016
    Member:
    #2304
    Messages:
    1,010
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 4Runner Trail Premium w/ KDSS
    I'm sure you did but you have changed out all the bulbs right?
     
  3. May 9, 2018 at 6:06 PM
    #3
    chuck

    chuck [OP] New Member

    Joined:
    Apr 2, 2018
    Member:
    #5760
    Messages:
    4
    Gender:
    Male
    First Name:
    chuck
    Vehicle:
    1995 4runner
    All bulbs work. I was hoping to get help from somebody that was an expert on these cars, not trolling.
     
  4. May 10, 2018 at 12:49 PM
    #4
    jester243

    jester243 rabble rabble rabble

    Joined:
    Jul 13, 2016
    Member:
    #2304
    Messages:
    1,010
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 4Runner Trail Premium w/ KDSS
    what in the actual fuck, was this at me? How the hell am I trolling, its a simple fucking question and the first god damn spot to start when turn signals don't work...
     
    Backslider likes this.
  5. May 10, 2018 at 4:42 PM
    #5
    chuck

    chuck [OP] New Member

    Joined:
    Apr 2, 2018
    Member:
    #5760
    Messages:
    4
    Gender:
    Male
    First Name:
    chuck
    Vehicle:
    1995 4runner
    Well I'm sorry if you weren't trolling me, but the original post states that all bulbs stay lit. Also, If I was competent enough to bench test the flasher, don't you think I was competent enough to see if the bulbs were burnt out. Additionally, if a bulb is burnt out the signal flashes at double speed not stays on.
     
    Last edited: May 10, 2018
  6. May 10, 2018 at 4:56 PM
    #6
    jester243

    jester243 rabble rabble rabble

    Joined:
    Jul 13, 2016
    Member:
    #2304
    Messages:
    1,010
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 4Runner Trail Premium w/ KDSS
    @chuck, I bet your fun at parties...good luck on your repair
     
  7. May 12, 2018 at 3:50 AM
    #7
    Guttiirunner

    Guttiirunner New Member

    Joined:
    Apr 18, 2017
    Member:
    #3902
    Messages:
    8
    Gender:
    Male
    Castroville
    Vehicle:
    90 4runner 4x4
  8. May 12, 2018 at 8:38 AM
    #8
    4X4Runner

    4X4Runner Moderator Staff Member

    Joined:
    Apr 3, 2014
    Member:
    #2
    Messages:
    328
    Gender:
    Male
    The east coast
    Vehicle:
    2017 4Runner Smashed Ass Edition
    Mad driver mod. OME Suspension. 285/70R17 BFG AT KO2
    Jesus Christ!!!

    Guy asks a question and states what he has done to troubleshoot, respondents skim over post and interject, OP gets frustrated and asks he not be trolled, respondent flies off handle and somehow it’s the OP’s fault.

    That’s how I read it.

    Everyone calm the fuck down.
     
  9. May 12, 2018 at 7:03 PM
    #9
    jester243

    jester243 rabble rabble rabble

    Joined:
    Jul 13, 2016
    Member:
    #2304
    Messages:
    1,010
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 4Runner Trail Premium w/ KDSS
    Didn’t skim over it I was just asking if he changed the bulbs...if that is now considered trolling I think I’m done with the internet.
     
  10. May 12, 2018 at 8:49 PM
    #10
    4X4Runner

    4X4Runner Moderator Staff Member

    Joined:
    Apr 3, 2014
    Member:
    #2
    Messages:
    328
    Gender:
    Male
    The east coast
    Vehicle:
    2017 4Runner Smashed Ass Edition
    Mad driver mod. OME Suspension. 285/70R17 BFG AT KO2
    He said it in his post. They are lit. He also tested the flasher, 3 of them.

    Had you read and interpreted his post, your post comes across as condescending, hence his response.

    Now, had you said. Have you tried testing for shorts? Disconnect each connector and test for resistance to ground. Or something to that effect would have been more helpful than “I’m sure you have but have you changed out all you bulbs yet?”

    It’s literally like asking why my car won’t start and having a response of “i know you checked but is there gas in it?”
     
  11. May 12, 2018 at 9:42 PM
    #11
    jester243

    jester243 rabble rabble rabble

    Joined:
    Jul 13, 2016
    Member:
    #2304
    Messages:
    1,010
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 4Runner Trail Premium w/ KDSS
    It was a simple question, maybe i should have asked if he's checked the sockets too. I'm not a mechanic i dont have a clue on electrical it was a bump up on a post that was falling to the bottom of the page. for Christs sake i don't care anymore i'm done with it
     
    alittleoff likes this.

Products Discussed in

To Top