1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Too much gas and no power!

Discussion in '2nd Gen 4Runners (1990-1995)' started by Shane Bice, Mar 23, 2015.

  1. Mar 23, 2015 at 5:28 PM
    #1
    Shane Bice

    Shane Bice [OP] New Member

    Joined:
    Mar 23, 2015
    Member:
    #524
    Messages:
    1
    Gender:
    Male
    Vehicle:
    1995 Toyota 4Runner SR5 3.0 V6
    Hello,
    My 95 4Runner SR5 3.0 V6 is getting about 5 miles to the gallon and has no guts after the CHECK ENGINE light comes on. So far, we have changed the knock sensor and the 02 sensor. The timing is right. We've pulled the plugs...all were in good shape,but one was really clean.So, we changed the fuel injector for the lean plug.Still the code is 52. I don't know what to do.Now I'm guessing it is the computer.Any ideas or help would be greatly appreciated. Thanks
     
  2. Mar 27, 2015 at 8:34 AM
    #2
    Bob

    Bob Member Staff Member

    Joined:
    Apr 3, 2014
    Member:
    #1
    Messages:
    986
    First Name:
    Bob
    SoCal
    Welcome to the site. Any updates on this?
     
  3. Jun 6, 2015 at 9:23 AM
    #3
    dalynda

    dalynda New Member

    Joined:
    May 10, 2014
    Member:
    #118
    Messages:
    2
    Gender:
    Female
    Nevada
    Vehicle:
    1993 Green 4Runner, manual
    You should definitely try replacing the Mass Air Flow. I was having a little trouble with no power before but getting a better MAF helped with that. Changing the knock sensor and the MAF should put you where it wants to be, I'm hoping.
     
    Bob likes this.
  4. Jun 11, 2015 at 8:09 AM
    #4
    BestGen

    BestGen Huge Member

    Joined:
    Apr 12, 2014
    Member:
    #57
    Messages:
    262
    Gender:
    Male
    First Name:
    Paul
    Whittier Hills, CA
    Vehicle:
    1988 4Runner 22RE/W56, 4.88s, Spartan Locker, AllPro Sliders, BFG 33/10.5s, 4Crawler 1.5" BJS, OME 2" Dakar springs
    33"KM2s, 4.88s, Spartan lkr, TG rear bumper, AllPro Kickout sliders, 4Crawler 1.5" BJS, OME 2" Dakar springs.
    You know when I first saw this thread title I thought to myself, "oh good! I'm not the only one who's feeling this way."
     
  5. Jun 11, 2015 at 1:36 PM
    #5
    Utah

    Utah Misanthrope

    Joined:
    Jul 31, 2014
    Member:
    #213
    Messages:
    194
    First Name:
    Kevin
    Land of Fake Beer
    Vehicle:
    The Gray Bastard
    3RZ, OME, 5.29s, 4.7, locked/locked
    Code 52 didn't have to be a bad sensor. The harness pigtail is known for going bad on that motor.
     
To Top