1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Replacing Brake Actuator Assembly in my 2015

Discussion in '5th Gen 4Runners (2010-2024)' started by Checook, Jul 4, 2019.

  1. Jul 4, 2019 at 10:41 PM
    #1
    Checook

    Checook [OP] New Member

    Joined:
    Sep 30, 2018
    Member:
    #7324
    Messages:
    58
    Gender:
    Male
    First Name:
    Che
    Vehicle:
    15 4runner SR5 4x4 Silver
    I am loosing my mind with the vacuum leak in the brake pedal. Every time I depress it slowly it makes a loud hiss/whoosh. I have Misophonia.....and it is driving me friggin nuts. Imagine your brake pedal making the sound of a screaming baby. I tried lubing it, wrapping it with insulative foam, rubber rejuvenation spray and sealing the rubber boot holes. The insulation helped but did not make the noise go away.

    My plan is to buy a used unit that I can work on and test, maybe swap some o-rings. Has anyone ever done this? Any special instructions other than bleeding the brakes? Any FSM info would be awesome.

    Thanks in advance.
     
  2. Jul 4, 2019 at 11:11 PM
    #2
    4X4Runner

    4X4Runner The Anti Pro, Pro! Staff Member

    Joined:
    Apr 3, 2014
    Member:
    #2
    Messages:
    1,533
    Gender:
    Male
    The left coast
    Vehicle:
    2017 4Runner Smashed Ass Edition
    Mad driver mod. OME Suspension. 285/70R17 BFG AT KO2
    I think what you’re hearing is what every 4Runner brake pedal sounds like. Someone else posted something similar regarding misophonia and the sound. I turned down my audio volume and listened for it and sure as shit, mine makes the same noise.

    I’ve actually tried listening to it in different vehicles and everything from Chevy, Ford, Nissan and dodge make the same noise. I think it’s the plunger/piston in the master cylinder making the noise.
     
    toy33 likes this.
  3. Jul 4, 2019 at 11:13 PM
    #3
    4X4Runner

    4X4Runner The Anti Pro, Pro! Staff Member

    Joined:
    Apr 3, 2014
    Member:
    #2
    Messages:
    1,533
    Gender:
    Male
    The left coast
    Vehicle:
    2017 4Runner Smashed Ass Edition
    Mad driver mod. OME Suspension. 285/70R17 BFG AT KO2
    I understand the sound sensitivity. While not diagnosed with it, there are sounds that will damn near send me into a rage. Sadly, it’s why I don’t own dogs.
     
  4. Jul 5, 2019 at 11:01 AM
    #4
    Checook

    Checook [OP] New Member

    Joined:
    Sep 30, 2018
    Member:
    #7324
    Messages:
    58
    Gender:
    Male
    First Name:
    Che
    Vehicle:
    15 4runner SR5 4x4 Silver
    My mother bought a 2015 Unlimited 4x4 after I bought my 2015 SR5 4x4 and hers doesn't make the noise. I found a good deal on the brake actuator assembly out of a 4x2 w/o active traction control. I don't suppose anyone knows if this would be compatible with mine if I swap the ABS control unit to it? They appear identical.
     
  5. Jul 5, 2019 at 12:13 PM
    #5
    Dillusion

    Dillusion New Member

    Joined:
    Dec 10, 2018
    Member:
    #7998
    Messages:
    1,945
    Gender:
    Male
    First Name:
    KYle
    Vehicle:
    2018 TRD OR
    Mine made the noise a lot when stock.

    Now that you mention it after the lift I don't think its as loud. I'm going to listen for it.
     
  6. Jul 15, 2019 at 12:51 AM
    #6
    Checook

    Checook [OP] New Member

    Joined:
    Sep 30, 2018
    Member:
    #7324
    Messages:
    58
    Gender:
    Male
    First Name:
    Che
    Vehicle:
    15 4runner SR5 4x4 Silver
    Used brake actuator with 12,000 miles pulled apart. Now to pray this one doesn't make the squish sound, pull the old one, pray the cylinder is the same, try not to spill brake fluid everywhere, assemble, reinstall, bleed brakes.....then more praying.

    IMG_20190715_004035.jpg
    IMG_20190715_003918.jpg
    IMG_20190715_002357.jpg
     
  7. Jul 16, 2019 at 2:34 AM
    #7
    Checook

    Checook [OP] New Member

    Joined:
    Sep 30, 2018
    Member:
    #7324
    Messages:
    58
    Gender:
    Male
    First Name:
    Che
    Vehicle:
    15 4runner SR5 4x4 Silver
    Swapped the actuator. Swapped the pump, wasn't going to but it got cross threaded. Reinstalled. No leaks! Started it up with no codes. I hit the soft pedal and ABS goes off, probably just needs a good flush tomorrow. And!!! The squish sound.....yeah, this one fucking does it too. God, why do you hate me?

    IMG_20190716_013846.jpg
    IMG_20190716_013830.jpg
     
  8. Jul 20, 2019 at 12:32 AM
    #8
    Checook

    Checook [OP] New Member

    Joined:
    Sep 30, 2018
    Member:
    #7324
    Messages:
    58
    Gender:
    Male
    First Name:
    Che
    Vehicle:
    15 4runner SR5 4x4 Silver
    Flushing the system got it back to normal with the squish. No ABS light. Took the original cylinder apart. No obvious bad rings. I would swap them out but some of them seem proprietary. How the heck does Toyota see this as okay?! Maybe I'll try to find another unit around income tax time and roll the $300+ dollar dice. Ughhhh....

    IMG_20190720_001529.jpg
    IMG_20190720_001903.jpg
    IMG_20190720_002733.jpg
     

Products Discussed in

To Top