1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Radio, dome lights not working

Discussion in '4th Gen 4Runners (2003-2009)' started by Maconedime, Aug 7, 2016.

  1. Aug 7, 2016 at 6:50 PM
    #1
    Maconedime

    Maconedime [OP] New Member

    Joined:
    Feb 23, 2016
    Member:
    #1609
    Messages:
    5
    Gender:
    Male
    First Name:
    Michael
    Vehicle:
    08 limited
    08 limited
    So my radio will not come on I've checked the fuses and they are fine. However I checked the fuses electronically and they had no power . Can someone tell me what I should do next?

    Thanks
     
  2. Aug 8, 2016 at 4:34 AM
    #2
    RonT4R

    RonT4R New Member

    Joined:
    Mar 24, 2015
    Member:
    #526
    Messages:
    515
    Gender:
    Male
    First Name:
    Ron
    Virginia Beach
    Vehicle:
    2007 4runner SR5 4WD
    There is probably either an accessory relay or fuse before the radio.....
     
  3. Aug 8, 2016 at 1:54 PM
    #3
    Maconedime

    Maconedime [OP] New Member

    Joined:
    Feb 23, 2016
    Member:
    #1609
    Messages:
    5
    Gender:
    Male
    First Name:
    Michael
    Vehicle:
    08 limited
    I figured it out .. It was the short pin .
    Thanks
     

Products Discussed in

To Top