1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

PO 174

Discussion in '4th Gen 4Runners (2003-2009)' started by another-bill, Mar 25, 2018.

  1. Mar 25, 2018 at 11:16 AM
    #1
    another-bill

    another-bill [OP] New Member

    Joined:
    Mar 24, 2018
    Member:
    #5716
    Messages:
    14
    Gender:
    Male
    First Name:
    Bill
    Vehicle:
    2005 Gold 4Runner SR5 V8
    Weather Tech mats! lol
    New member here and a new 4Runner owner.

    So, I bought a 2005 V-8 4.7 4Runner SR5 2WD with 157,000 miles. A few days afterwards it starts showing the check engine light along with the VSC/TC lights. I run the code and get PO174.

    I replaced the air filter and MAF, nothing. Replaced the PCV and gas cap, nothing.

    Took it to a shop I trust and they smoke tested it which showed it needed the PCV hose, intake manifold gasket set, fuel injector O-ring and fuel injector cushion ring-lower which were all changed and 10 miles later I am again getting PO171 & PO174.

    ETA, the shop tested the fuel pressure and it was within spec.

    The only thing I can guess is the O2 sensors?



    Any ideas?
     
  2. Jun 21, 2020 at 4:47 PM
    #2
    4Banger98

    4Banger98 New Member

    Joined:
    Jun 10, 2020
    Member:
    #14843
    Messages:
    7
    Gender:
    Male
    First Name:
    J
    Las Vegas
    Vehicle:
    98 4RUNNER 2.7 MANUAL 4x4
    3' lift, 2 inch wheel spacers, Durabak hood, fenders, roof, leather seats, Tacoma wheels, remanufactured engine, was base model
    PO171 130 133 here. 171 is supposedly a vac leak somewhere that I can't find, running out of ideas. I replaced both the o2 sensors and it did nothing.
     
  3. Jun 24, 2020 at 4:03 AM
    #3
    captsolo

    captsolo New Member

    Joined:
    Jun 2, 2019
    Member:
    #10131
    Messages:
    169
    Gender:
    Male
    First Name:
    Tom
    nassau bahamas
    Vehicle:
    2005 SR5
    How does it run?
     
  4. Jun 24, 2020 at 10:13 AM
    #4
    4Banger98

    4Banger98 New Member

    Joined:
    Jun 10, 2020
    Member:
    #14843
    Messages:
    7
    Gender:
    Male
    First Name:
    J
    Las Vegas
    Vehicle:
    98 4RUNNER 2.7 MANUAL 4x4
    3' lift, 2 inch wheel spacers, Durabak hood, fenders, roof, leather seats, Tacoma wheels, remanufactured engine, was base model
    Runs pretty good but burns gas, exhaust discolored. System too lean. Intake gaskets new. PO133 slow response which should be wiring, but I have not found broken wires. Replaced almost everything that could be related.
     
  5. Jun 24, 2020 at 2:57 PM
    #5
    captsolo

    captsolo New Member

    Joined:
    Jun 2, 2019
    Member:
    #10131
    Messages:
    169
    Gender:
    Male
    First Name:
    Tom
    nassau bahamas
    Vehicle:
    2005 SR5
    Find a better mechanic!

    My 2005 with 150,000 miles runs like a top (new), and has never been worked on except for oil and filter every 4000 miles, 4 starters (replaced in my driveway for $60 to mechanic). Starters $100 at Amazon.com OK.

    Original water pump, alternator, tranny (fluid and filter once at 105,000 miles at dealer), all original exhaust (this amazes me).

    4runner has never thrown a "code" on the dash in 15 years.

    Long life Coolant change D/F (10 quarts) in the driveway once at 100,000 miles by owner. I think 4runner holds 10 quarts of Zerex Asian coolant. https://www.valvoline.com/our-products/antifreeze-products/zerex-asian-vehicle-antifreeze-coolant
     
    Last edited: Jul 1, 2020
  6. Jun 30, 2020 at 4:16 PM
    #6
    4Banger98

    4Banger98 New Member

    Joined:
    Jun 10, 2020
    Member:
    #14843
    Messages:
    7
    Gender:
    Male
    First Name:
    J
    Las Vegas
    Vehicle:
    98 4RUNNER 2.7 MANUAL 4x4
    3' lift, 2 inch wheel spacers, Durabak hood, fenders, roof, leather seats, Tacoma wheels, remanufactured engine, was base model
    Then your lucky. 300k miles when I bought this, had every problem you could imagine. I have fixed pretty close to everything. Over 6k in parts alone not counting new engine block. I am my own mechanic, I don't need monkey's touching my vehicles. FYI PO171 is fixed since it was one of the last hoses to replace. I do not run a CAT but that code is solved too. Put another 150k on it and see what you will have to replace.
     

Products Discussed in

To Top