1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

p0171

Discussion in '3rd Gen 4Runners (1996-2002)' started by rmz489, Apr 20, 2016.

  1. Apr 20, 2016 at 7:49 AM
    #1
    rmz489

    rmz489 [OP] New Member

    Joined:
    Apr 7, 2016
    Member:
    #1837
    Messages:
    10
    Gender:
    Male
    First Name:
    Austin
    Vehicle:
    2001 forest green sr5 4runner
    3 in' lift,atermakret wheels, intake, flomaster exahaust, tundra adjustable front shocks
    Hey guys, I figured I would go at this a second time with a little more educated a post. I'm throwing a lean code p0171 on my 03 4runner. The code fired after I had taken the truck out in the desert for some fun for the first time. The Mass airflow sensor was really dirty, so I cleaned that, cleared the code, and the code fired again. anyone have advice on where to proceed ? possible 02 sensor, vacuum leak?
     
  2. Apr 20, 2016 at 3:26 PM
    #2
    irishfury

    irishfury New Member

    Joined:
    Jan 27, 2016
    Member:
    #1460
    Messages:
    28
    Gender:
    Male
    First Name:
    Sean
    Birmingham, Alabama
    Vehicle:
    1999 Black 4Runner Limited 4wd
    I've seen some posts about two wires inside the mass airflow sensor that need to be cleaned. Did you happen clean those? There are some other troubleshooting tips in the following link such as checking for leaks in the vacuum tubes.
     
    rmz489 [OP] likes this.
  3. May 19, 2016 at 2:43 AM
    #3
    RussToy

    RussToy New Member

    Joined:
    Sep 7, 2015
    Member:
    #953
    Messages:
    102
    Gender:
    Male
    First Name:
    Russel Lee
    Granville Ohio
    Vehicle:
    2000 4Runner SR5
    A Work in Progress
    Did you get this fixed?
     
  4. May 19, 2016 at 5:35 PM
    #4
    rmz489

    rmz489 [OP] New Member

    Joined:
    Apr 7, 2016
    Member:
    #1837
    Messages:
    10
    Gender:
    Male
    First Name:
    Austin
    Vehicle:
    2001 forest green sr5 4runner
    3 in' lift,atermakret wheels, intake, flomaster exahaust, tundra adjustable front shocks
    The light actually turned off on its own and has been off since
     

Products Discussed in

To Top