1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

P0120 Has me perplexed

Discussion in '3rd Gen 4Runners (1996-2002)' started by gprust, Dec 29, 2016.

  1. Dec 29, 2016 at 2:53 PM
    #1
    gprust

    gprust [OP] New Member

    Joined:
    Dec 29, 2016
    Member:
    #3253
    Messages:
    1
    Gender:
    Male
    Good afternoon,

    I have been chasing a P0120 code for a few weeks now. I just purchased my 2002 4runner SR5 about 4 months ago. It now has just under 92k.

    Problems started when I was on the highway and noticed it sputter a little. I pulled off and the throttle wouldn't respond until it was 1/2 to about 2/3 pressed in. Took it to Autozone, they pulled code P0120 and another one for a minor vacuum leak. I was able to find a used throttle position sensor and put in on my throttle body. It worked great and ran better for about 3 days.

    I was again driving along the highway for about 45 minutes when I noticed it sputter again. Same thing: no throttle response until the pedal was 1/2 to 2/3 pressed down. I was staying out of town, so I nursed it to where I was going. On the way back the following morning, it worked great for about 30 minutes. Then the same behavior. We left it parked for about a week.

    I changed out the coolant temperature sensor, thinking maybe the issue was temperature related. Didn't fix it.

    Fast forward another week, I went to the salvage yard and pulled one TPS and one whole throttle body. The TPS didn't fix it. Then I tried the whole other throttle body. Still didn't work. And now, the truck is harder to start and I have to have the pedal pressed it to get it to start!

    Today, I went and pulled two ECU from the salvage yard. I changed one out, double checked all my fuses. It started better but same throttle reaction. I tried again later in the afternoon and had to press the pedal to get the truck to start during cranking.

    I'm at a complete loss. Any pointers would be greatly appreciated.
     
  2. Dec 30, 2016 at 4:13 PM
    #2
    TN_TRAIL

    TN_TRAIL New Member

    Joined:
    Dec 24, 2016
    Member:
    #3237
    Messages:
    105
    Gender:
    Male
    First Name:
    Noel
    Vehicle:
    2017 TRD OFF RD PREM
    oh the list....!
    First rule of troubleshooting. LFS. Look for Stuff. Check the wiring harness that is related to the TPS for "iffy" connections. If you have a code reader, you should also (with a number of them) be able to clear codes. Also, you will then be able to do a spot check between the "A" circuit output of the TPS, and the "B" circuit as well, to verify the failure. I'd personally look for rodent chewed wires to start with.
    When the ECU detects this failure, (again depending on the Manufacturer) If will set the check engine light, and possibly put your system into a "limp" mode that will produce your EXACT complaint. Best of luck.
     

Products Discussed in

To Top