1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

O2 sensors and bad gas mileage

Discussion in '3rd Gen 4Runners (1996-2002)' started by FlyerG, Oct 9, 2015.

  1. Oct 9, 2015 at 1:07 PM
    #1
    FlyerG

    FlyerG [OP] New Member

    Joined:
    Oct 9, 2015
    Member:
    #1050
    Messages:
    1
    Vehicle:
    1998 4runnr 4wd Limited
    I get horrible gas mileage on my 98 4x4 and had a check engine light. I read that bad o2 sensors were the likely culprit, so I had them replaced. Not more than three weeks later, the check engine light is on again and my mileage is still bad (around 200 miles per tank). What would cause the sensors to go bad?
     
  2. Oct 9, 2015 at 2:43 PM
    #2
    nj636

    nj636 New Member

    Joined:
    Apr 18, 2014
    Member:
    #75
    Messages:
    188
    First Name:
    Kevin
    Vehicle:
    2006 Radiant Red Tacoma Double Cab Short Bed
    OME lift / 285's / Armor
    what code did you have.
     
  3. Oct 10, 2015 at 11:24 AM
    #3
    Ol'Blue

    Ol'Blue Moderator Staff Member

    Joined:
    Apr 12, 2014
    Member:
    #55
    Messages:
    1,376
    Gender:
    Male
    "Not all who wander are lost"
    Vehicle:
    99 T4R LTD- 33's and locked, 01 SR5-,SAS Sold...
    A few things here and there. Still dreaming up stuff
    More than likely if the fule milage is that bad it is not an o2. It's your a/f sensor. I know when mine went out I dropped down to 6mph.

    Did you replace an o2? Old age will take them out most the time. Also if you get an o2 or a/f sensor use the denso. They work the best and last!


    Blue
     
  4. Oct 19, 2015 at 3:37 AM
    #4
    RussToy

    RussToy New Member

    Joined:
    Sep 7, 2015
    Member:
    #953
    Messages:
    102
    Gender:
    Male
    First Name:
    Russel Lee
    Granville Ohio
    Vehicle:
    2000 4Runner SR5
    A Work in Progress
    ^^^what @nj636 asked^^^

    What was your original code when your first CEL came on? Then what was the code when your 2nd CEL came on after you replaced your O2 sensor??

    Also...for thoes 3 weeks, did you get your "normal" gas mileage once you changed the O2 sensor? If so...once your CEL came back on...did you again go back to bad gas mileage?

    - Russel
     

Products Discussed in

To Top