1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Hi guys glad to be a member! Need help with 87 4 runner

Discussion in 'New Member Introductions' started by 87runner, Dec 19, 2017.

  1. Dec 19, 2017 at 8:09 AM
    #1
    87runner

    87runner [OP] New Member

    Joined:
    Dec 18, 2017
    Member:
    #5177
    Messages:
    3
    Gender:
    Male
    Trying to get used to the forum. I have an 87 4 runner I need some help with. Thanks
     
  2. Dec 19, 2017 at 8:34 AM
    #2
    Wheeler's Off-Road Inc

    Wheeler's Off-Road Inc New Member

    Joined:
    Nov 9, 2017
    Member:
    #5015
    Messages:
    91
    Welcome! The search bar here is going to be your best friend to look for info. @codydoss has a really sweet build going on right now but has not been on the forum in a while.
     
  3. Dec 19, 2017 at 10:28 AM
    #3
    BestGen

    BestGen Member #57

    Joined:
    Apr 12, 2014
    Member:
    #57
    Messages:
    955
    Gender:
    Male
    First Name:
    Paul
    Haunted Turnbull Canyon, CA
    Vehicle:
    1988 4Runner XTE 22RE/W56, '93 G144 4.88s, Spartan Locker, AllPro Sliders, OEM 15x6" rims, BFG KM2 33/10.5s, 4Crawler 1.5" BJS, OME 2" Dakar springs, TG rear bumper.
    33"KM2s, 4.88s, Spartan Locker, TG rear bumper, AllPro Kickout sliders, 4Crawler 1.5" BJS, OME 2" Dakar springs.
    Welcome aboard! Any pics? What's the problem specifically?
     
  4. Dec 19, 2017 at 2:23 PM
    #4
    87runner

    87runner [OP] New Member

    Joined:
    Dec 18, 2017
    Member:
    #5177
    Messages:
    3
    Gender:
    Male
    Thanks, this truck has been sitting for 6 years. 119,000 one owner miles. 22RE I have cleaned the fuel tank and installed a new fuel pump and filter. I have fuel pressure in the fuel rail and a good blue spark at the plug but the injectors are not opening. I have power to them so I figure the ecm must be switching the ground. I am replacing the fuel injectors as they were leaking. I ran a hot wire and ground off the battery to them and they do not "click" and act like a dead short...maybe they are the problem but I am concerned the distributor and ecm are not communicating as far as when the engine is cranking. I don't understand what the 2 wires going to the ignitor do. Any help would be greatly appreciated.
     
  5. Feb 6, 2018 at 6:40 PM
    #5
    87runner

    87runner [OP] New Member

    Joined:
    Dec 18, 2017
    Member:
    #5177
    Messages:
    3
    Gender:
    Male
    Does anyone know any company making a gril guard for my 87 4Runner? Thanks
     

Products Discussed in

To Top