1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help with Codes/CEL/VSC Light came on

Discussion in '4th Gen 4Runners (2003-2009)' started by pat_sajak, Apr 21, 2017.

  1. Apr 21, 2017 at 1:37 PM
    #1
    pat_sajak

    pat_sajak [OP] New Member

    Joined:
    Apr 21, 2017
    Member:
    #3923
    Messages:
    2
    Gender:
    Male
    First Name:
    Caleb
    Vehicle:
    My Taco / Her Ho Runner
    Howdy! I'm on Tacoma world but I come seeking the help from you and your 4runner knowledge!!!!!


    Check engine and other lights came on this morning when my girlfriend was driving to work in her 4runner. hoping someone can give some insight as to what the codes could mean. showing up all at once.

    Codes:

    C1201
    C1223
    C1241
    C1256
    P0456

    I assumed it is an alternator/battery issue.

    I've read elsewhere it could be a bad sensor or a gas cap.

    Any input is greatly appreciated and any questions will be answered asap.


    sorry for the limited info im posting this at work in free time.. ask away
     
    Bob likes this.
  2. Apr 24, 2017 at 4:33 AM
    #2
    RonT4R

    RonT4R New Member

    Joined:
    Mar 24, 2015
    Member:
    #526
    Messages:
    548
    Gender:
    Male
    First Name:
    Ron
    Virginia Beach
    Vehicle:
    2007 4runner SR5 4WD
    I'll look up the codes.....
     
    Bob likes this.
  3. Apr 24, 2017 at 10:42 AM
    #3
    keakar

    keakar New Member

    Joined:
    Apr 20, 2017
    Member:
    #3914
    Messages:
    51
    Gender:
    Male
    louisiana
    Vehicle:
    2006 4runner sport 4.7L V8 (white)
    im new to learning about 4runners but the very first common problem on all 4th gens I started to read about was if you have any type of master cylinder, ABS, brake pressure pump, or brake booster, its an all in one unit that must be replaced and its not cheap, $2500 from dealer or $500 for aftermarket at auto store or ebay.

    google has a lot of info on the vsc abs traction control lights going off and I don't recall any solutions besides replacing that whole unit no matter which function goes bad.
     
  4. Apr 24, 2017 at 11:24 AM
    #4
    RonT4R

    RonT4R New Member

    Joined:
    Mar 24, 2015
    Member:
    #526
    Messages:
    548
    Gender:
    Male
    First Name:
    Ron
    Virginia Beach
    Vehicle:
    2007 4runner SR5 4WD
    First thing I would do is reset the lights and tighten the fuel cap and see if the problem returns. Sounds silly but when those lights popped up on my dash that is what I did and the problem has not returned.
     
  5. Apr 26, 2017 at 7:07 AM
    #5
    pat_sajak

    pat_sajak [OP] New Member

    Joined:
    Apr 21, 2017
    Member:
    #3923
    Messages:
    2
    Gender:
    Male
    First Name:
    Caleb
    Vehicle:
    My Taco / Her Ho Runner
    update: Was told the alternator's regulator was crapped out and wasn't fully charging the battery. We replaced the alternator as a whole yesterday, drove just fine. this morning it won't start. we are now suspecting that the battery won't hold a charge.

    Seems to me that we replaced our alternator for no good reason.
     
    keakar likes this.
  6. Apr 27, 2017 at 6:05 PM
    #6
    mr5vtps

    mr5vtps New Member

    Joined:
    Oct 5, 2016
    Member:
    #2785
    Messages:
    28
    Gender:
    Male
    First Name:
    Charles
    Vehicle:
    2008 Titanium Metallic 4x4 Urban Runner
    Stock
    I had the same problem on a 2008 4.0L. Replaced the gas cap and reset computer and problem has not returned.
     

Products Discussed in

To Top