1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Gas gauge issues

Discussion in '4th Gen 4Runners (2003-2009)' started by 50zach, Apr 13, 2019.

  1. Apr 13, 2019 at 10:38 PM
    #1
    50zach

    50zach [OP] New Member

    Joined:
    Apr 13, 2019
    Member:
    #9530
    Messages:
    13
    Gender:
    Male
    First Name:
    Zach
    Vehicle:
    2003 black limited 4runner
    Hi yall I'm new to the forum. I just picked myself up an 03 limited with 113k on her. Hoping she'll last me a very long time. So when I bought it I noticed that the range said 0. Thought that was weird but kept driving because the gauge registered 3/4 tank. I little further down the road the truck shutoff and my first thought was it was out of gas. Sure enough it was. I filled her up with gas and went and directly bought a new sending unit for 113 bucks from advanced auto. I just got done dropping the tank and replacing the unit and now it reads full tank but it's all the way near the park sign. When I shut off the truck it reads 3/4 as the end of the needle where it should rest. I tried doing the TSB to recalibrate the gauge but no luck. Also my range is back so its saying 396 miles. I am stumped.
     
  2. Apr 14, 2019 at 5:50 AM
    #2
    HoBoDanny

    HoBoDanny Dude...

    Joined:
    Feb 5, 2019
    Member:
    #8697
    Messages:
    997
    Gender:
    Male
    First Name:
    Daniel
    Kentucky
    Vehicle:
    2004 SR5 V6 4WD 4Runner
    RCI Skid Plate CBI Ditch Light Brackets Hankook DynaPro ATM RF10 265 70R17 113T Tires 1.25” Wheel Spacers TPMS Bypass Mod Hydrocarbon Filter Removed Merca decal 2” leveling kit front only Black headlights
    Maybe take the cover off the cluster and see if the gauge is stuck? Could buy a new cluster if it is.
     
  3. Apr 14, 2019 at 4:36 PM
    #3
    50zach

    50zach [OP] New Member

    Joined:
    Apr 13, 2019
    Member:
    #9530
    Messages:
    13
    Gender:
    Male
    First Name:
    Zach
    Vehicle:
    2003 black limited 4runner
    I thought it was stuck too but it moves which is weird
     
  4. Apr 22, 2019 at 8:05 PM
    #4
    RomaniGypsy

    RomaniGypsy New Member

    Joined:
    Nov 23, 2017
    Member:
    #5081
    Messages:
    25
    Gender:
    Male
    Vehicle:
    2004 4Runner SR5 4WD, 2014 Prius v, 1972 Cadillac Calais
    Sounds similar to my problem. My gas gauge needle is stuck reading about 1/4 of a tank less than what I actually have. The range display works, and the gas gauge is quite accurate if you just add 1/4 of a tank to whatever it reads. It's been consistent... almost like all I'd have to do is pop the needle off, twist it a few degrees counterclockwise, pop the needle back on, and everything would be displaying properly.
     
  5. May 5, 2019 at 8:32 AM
    #5
    Jere

    Jere New Member

    Joined:
    May 5, 2019
    Member:
    #9770
    Messages:
    1
    Gender:
    Male
    First Name:
    Jere
    Vehicle:
    2007 SR5 V6 2WD White
    RRO Sliders, Bilstein 5100 leveling with Toytec 1/4 spacer on drivers side, Exterior chrome replaced with Limited White ,Interior LEDs, Roof Rack delete with Rhino Rack Ditch Mount rack
    Have gas guage problem too. Brought 2007 in November. Gauge would stick below amount in tank and read empty with 5 gallons in tank. Ran Techron and Rec Gas in tank and now sticking is gone. Gauge still reading empty with 5 gallons in tank. Empty light went on at 369miles and filled at 446miles with 21.5 gallons of gas yesterday. Have Toyota sender and I am going to get Toyota fuel Pump and drop tank. Anything elese I should look at?
     
  6. May 5, 2019 at 11:59 AM
    #6
    50zach

    50zach [OP] New Member

    Joined:
    Apr 13, 2019
    Member:
    #9530
    Messages:
    13
    Gender:
    Male
    First Name:
    Zach
    Vehicle:
    2003 black limited 4runner
    I solved my problem, I fixed my sender and after that my gauge actually moved then a full tank would register at almost the P for Park and empty would be 3/4 tank. I ended up only having to take out my cluster, open it up and physically move the needle to empty. Thank you Toyota for making that so easy (I come from pain in the butt fords)
     

Products Discussed in

To Top