1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Display went blank

Discussion in 'Audio & Video' started by DrewF, Mar 21, 2018.

  1. Mar 21, 2018 at 4:42 AM
    #1
    DrewF

    DrewF [OP] New Member

    Joined:
    Mar 21, 2018
    Member:
    #5695
    Messages:
    7
    Gender:
    Male
    Vehicle:
    2014 4Runner limited
    My display started flickering then went blank. Radio still plays but can't see backup camera or anything. Any ideas what the problem might be?
     
  2. Mar 21, 2018 at 9:47 AM
    #2
    jester243

    jester243 rabble rabble rabble

    Joined:
    Jul 13, 2016
    Member:
    #2304
    Messages:
    1,632
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 4Runner Trail Premium w/ KDSS
    RIP little head unit...

    You might find one for sale in here when people change them out.
     
  3. Mar 21, 2018 at 11:10 AM
    #3
    DrewF

    DrewF [OP] New Member

    Joined:
    Mar 21, 2018
    Member:
    #5695
    Messages:
    7
    Gender:
    Male
    Vehicle:
    2014 4Runner limited
    I did a software update and that didn't help. The screen was flickering again, and not totally blank, so I was able to update.
     
  4. Mar 21, 2018 at 1:30 PM
    #4
    ANNIE_GOT_A_RUN

    ANNIE_GOT_A_RUN New Member

    Joined:
    Mar 2, 2018
    Member:
    #5577
    Messages:
    69
    Gender:
    Male
    Vehicle:
    2018 4runner SR5 Premium
    3inch Revtek level kit, 285/70/17 Toyo Open Country AT's
    what year do you have? I am having issues with the lower left corner of my 2018 SR5 Premium.
     
  5. Mar 21, 2018 at 1:52 PM
    #5
    DrewF

    DrewF [OP] New Member

    Joined:
    Mar 21, 2018
    Member:
    #5695
    Messages:
    7
    Gender:
    Male
    Vehicle:
    2014 4Runner limited
    2014 Limited
     
  6. Jun 23, 2018 at 2:47 PM
    #6
    jknight304

    jknight304 New Member

    Joined:
    Jun 23, 2018
    Member:
    #6322
    Messages:
    2
    Gender:
    Male
    2014 SR5 4runner
    I am having the same problem with my 2014 SR5. It started flickering and did that for several days. Now it is completely black. Radio works but can't see anything. Spoke to Toyota and they said all they can do is replace the unit.
     
  7. Jun 23, 2018 at 3:42 PM
    #7
    JBTRD

    JBTRD As usual, saying something stupid

    Joined:
    Apr 2, 2016
    Member:
    #1809
    Messages:
    585
    Gender:
    Male
    First Name:
    Jeremy
    Bryan, Texas
    Vehicle:
    2016 (The Real) Trail Edition
    My dad’s 2015 tundra did the same thing, luckily it was still under warrenty.
     
    PJAC and DrewF [OP] like this.
  8. Jul 23, 2018 at 5:37 PM
    #8
    BluHeaven14

    BluHeaven14 New Member

    Joined:
    May 18, 2016
    Member:
    #2029
    Messages:
    12
    Gender:
    Male
    First Name:
    Bryan
    Vehicle:
    2014 Blue 4Runner SR5
    2014 SR5 screen went white on the way into work last week. Lost everything. No radio, no GPS, no back-up cam. Had to pull fuse cuz white screen stayed on after engine was off and doors were locked. Toyota said it needs to be replaced. Just under $1k. It better have the updated GPS.
     
  9. Jul 23, 2018 at 6:08 PM
    #9
    jknight304

    jknight304 New Member

    Joined:
    Jun 23, 2018
    Member:
    #6322
    Messages:
    2
    Gender:
    Male
    2014 SR5 4runner
    Is that for the whole unit or just the screen?
     
  10. Jul 23, 2018 at 6:09 PM
    #10
    PJAC

    PJAC New Member

    Joined:
    May 26, 2018
    Member:
    #6106
    Messages:
    83
    Gender:
    Female
    Texas
    Vehicle:
    2017 4Runner- MGM TRD ORP
    RSG Sliders w/ kickout Shrockworks Skids Baja squadron sport ditch lights & Baja fog lights (both are Amber) SSO offroad roof rack JBA UCAs Eibach suspension NoxLux black-out emblems MaxTrax recovery boards SCS ray 10's BFG ko2's -285/70/17 Stay tuned...more mods coming very soon including new suspension & much more
    @DrewF did you figure out why your screen went black and flickered. Mine did the same thing yesterday and the dealership told me it might need a software update & if that didn’t fix it they will replace the radio.
     
  11. Jul 23, 2018 at 6:11 PM
    #11
    PJAC

    PJAC New Member

    Joined:
    May 26, 2018
    Member:
    #6106
    Messages:
    83
    Gender:
    Female
    Texas
    Vehicle:
    2017 4Runner- MGM TRD ORP
    RSG Sliders w/ kickout Shrockworks Skids Baja squadron sport ditch lights & Baja fog lights (both are Amber) SSO offroad roof rack JBA UCAs Eibach suspension NoxLux black-out emblems MaxTrax recovery boards SCS ray 10's BFG ko2's -285/70/17 Stay tuned...more mods coming very soon including new suspension & much more
    @BluHeaven14 mine went black but I had no sound, no camera no nothing then all the sudden it decided to come on again. Dealership told me to bring it in tomorrow to check it out. Service tech said might need update on software & if not they will replace the radio.
     
  12. Jul 23, 2018 at 7:33 PM
    #12
    BluHeaven14

    BluHeaven14 New Member

    Joined:
    May 18, 2016
    Member:
    #2029
    Messages:
    12
    Gender:
    Male
    First Name:
    Bryan
    Vehicle:
    2014 Blue 4Runner SR5
    Price is for full unit swap..
     
  13. Jul 24, 2018 at 7:38 AM
    #13
    PJAC

    PJAC New Member

    Joined:
    May 26, 2018
    Member:
    #6106
    Messages:
    83
    Gender:
    Female
    Texas
    Vehicle:
    2017 4Runner- MGM TRD ORP
    RSG Sliders w/ kickout Shrockworks Skids Baja squadron sport ditch lights & Baja fog lights (both are Amber) SSO offroad roof rack JBA UCAs Eibach suspension NoxLux black-out emblems MaxTrax recovery boards SCS ray 10's BFG ko2's -285/70/17 Stay tuned...more mods coming very soon including new suspension & much more
    At the dealership now with mine & they told me what’s happening is they are replacing all the radios after the update doesn’t work & once they get back to factory they test them & they work. They are thinking that if you have devices paired to your system it could be the device and not the unit. Mine just requires the update because I don’t have a phone or device connected to it. Might need to do a factory reset then update the system.
     
    BluHeaven14 likes this.
  14. Jul 25, 2018 at 11:29 AM
    #14
    DrewF

    DrewF [OP] New Member

    Joined:
    Mar 21, 2018
    Member:
    #5695
    Messages:
    7
    Gender:
    Male
    Vehicle:
    2014 4Runner limited
    @PJAC I never figured out why it went blank and haven't replaced my unit. Also haven't talked with dealer lately but maybe I should? As I mentioned above, I was able to do the software update myself because the screen stayed active long enough and the dealer wanted to charge me for it. The screen is still going in and out, though. I don't remember if there was a factory reset option that I could do myself. Do you think that I should I contact the dealer again?
     
  15. Jul 28, 2018 at 4:56 PM
    #15
    PJAC

    PJAC New Member

    Joined:
    May 26, 2018
    Member:
    #6106
    Messages:
    83
    Gender:
    Female
    Texas
    Vehicle:
    2017 4Runner- MGM TRD ORP
    RSG Sliders w/ kickout Shrockworks Skids Baja squadron sport ditch lights & Baja fog lights (both are Amber) SSO offroad roof rack JBA UCAs Eibach suspension NoxLux black-out emblems MaxTrax recovery boards SCS ray 10's BFG ko2's -285/70/17 Stay tuned...more mods coming very soon including new suspension & much more
    @DrewF I think you should! just be straightforward with your service tech and let him know that you are aware of this screen issue and you’d like for them to follow their protocol per the factory which should be check the actual unit for any foreign objects or other issues with visual inspection (coins and other crazy stuff that small children might stick in the CD slot), if nothing then they will do the update. If the system update fails and problem persists & you’ve had or currently have any device or phone paired with your system then it will need to be unpaired, cleared and they will then perform a factory reset.
    The factory reset is the final step before replacing the actual unit.
    That’s what my Toyota service tech and department told me. I hope it works out for you.
     
  16. Jul 29, 2018 at 3:29 PM
    #16
    DrewF

    DrewF [OP] New Member

    Joined:
    Mar 21, 2018
    Member:
    #5695
    Messages:
    7
    Gender:
    Male
    Vehicle:
    2014 4Runner limited
    @PJAC Thanks for the update. Is your 4Runner under warranty and did you get a new unit?
     
  17. Aug 20, 2018 at 1:23 PM
    #17
    DrewF

    DrewF [OP] New Member

    Joined:
    Mar 21, 2018
    Member:
    #5695
    Messages:
    7
    Gender:
    Male
    Vehicle:
    2014 4Runner limited
    I contacted Toyota directly and they will not replace my unit because I'm not under warranty :(
     
  18. Jan 1, 2019 at 4:01 PM
    #18
    Txrunner

    Txrunner New Member

    Joined:
    Jan 1, 2019
    Member:
    #8291
    Messages:
    1
    What fuse do you pull to make the screen reset? Mine is white and staying lit after I turn off my car.
     
  19. Jan 1, 2019 at 4:07 PM
    #19
    ManBeast

    ManBeast New Member

    Joined:
    Dec 17, 2018
    Member:
    #8082
    Messages:
    322
    Gender:
    Male
    First Name:
    Zach
    Jax FL
    Vehicle:
    2014 TRAIL
    Id swap in a aftermarket deck at that cost
     
    jgcaps and SlvrSlug like this.
  20. Jan 2, 2019 at 8:05 PM
    #20
    DrewF

    DrewF [OP] New Member

    Joined:
    Mar 21, 2018
    Member:
    #5695
    Messages:
    7
    Gender:
    Male
    Vehicle:
    2014 4Runner limited
    I replaced mine with a Kenwood DNX575S. The sound quality is much better, even with stock speakers. Has nav and AA. $200 rebate. Unit functions really well. Waze can be finicky sometimes but in can easily switch to Google maps or Garmin if I need too. Radio is crappy, though, but there's always iHeart radio or whatever
     
  21. Jul 20, 2019 at 3:20 AM
    #21
    Phishears

    Phishears New Member

    Joined:
    Jul 20, 2019
    Member:
    #10622
    Messages:
    2
    Gender:
    Male
    First Name:
    Mark
    Vehicle:
    Toyota 4Runner 2014 Limited
    I have 2014 4Runner limited. Yesterday my unit blew like it had been hit by lightning or something. Very loud noise. Now I have the white screen that won’t turn off. Also told it would be $1000 to replace. Kills me as the unit has been shakey since day one. Often freezing and rebooting. I too need too need to figure out which fuse to pull. Anyone?
     
  22. Jul 20, 2019 at 3:40 AM
    #22
    Phishears

    Phishears New Member

    Joined:
    Jul 20, 2019
    Member:
    #10622
    Messages:
    2
    Gender:
    Male
    First Name:
    Mark
    Vehicle:
    Toyota 4Runner 2014 Limited
    Ok just went out this morning and unit is working again. Screen was white for at least 6 hours. All I did was pull fuse cover to see if I could figure out what fuse to pull. I’m not looking forward to the next time this thing freaks out. It was loud!
     

Products Discussed in

To Top