1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Brake fade while ABS engaged

Discussion in '4th Gen 4Runners (2003-2009)' started by va79ta, Jun 29, 2018.

  1. Jun 29, 2018 at 6:50 AM
    #1
    va79ta

    va79ta [OP] New Member

    Joined:
    Jun 29, 2018
    Member:
    #6371
    Messages:
    8
    Gender:
    Male
    First Name:
    Michael
    Bilstein 5100 shocks/struts with the adjustable fronts leveled.
    So I have a problem with my 07 (V6 with 115k miles) and the ABS brakes. When I brake hard and ABS kicks in it feels like the brakes stop working during the panic stop. I get the momentary stopage and the ABS kicks back in. I have almost been in one accident because of this issue. I try to be hyper-alert, but people are very unpredictable.

    What could be the possible issue? Computer reset? Worn hardware? I have replaced the shocks, struts, and tires. So the issue isn't with the tires losing contact with the road. I suspect this is going to be expensive to fix as it feels like an electronics problem.

    Thanks for any advice.
     
  2. Jun 29, 2018 at 12:39 PM
    #2
    jester243

    jester243 rabble rabble rabble

    Joined:
    Jul 13, 2016
    Member:
    #2304
    Messages:
    1,632
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 4Runner Trail Premium w/ KDSS
    not sure if it's exactly what you are experiencing but, on the 2nd gen Tacoma's guys were installing ABS kill switches. The reason being that on ice when you're trying to stop the stupid ABS just wont let the truck stop, I coasted through a couple of stop signs while standing on the pedal with the ABS pumping away the entire time. I changed tires to some BFG's and the better traction did help this not happen but not all the time. basically the ABS seems too sensitive, read one of the threads on TW: https://www.tacomaworld.com/threads/abs-kill-switch.424125/

    there are a few threads over there about it if you want.
     
  3. Jul 3, 2018 at 5:45 AM
    #3
    va79ta

    va79ta [OP] New Member

    Joined:
    Jun 29, 2018
    Member:
    #6371
    Messages:
    8
    Gender:
    Male
    First Name:
    Michael
    Bilstein 5100 shocks/struts with the adjustable fronts leveled.
    Thanks for the reply. My problem is more of the brakes almost stop working in mid panic stop. The ABS stops pulsing and there is a noticeable decrease in braking. I almost hit a person because of this. I suspect it's a control module or something else electronic. Just swapping parts will get very pricey. Would there be a trouble code stored in the computer? I don't see the brake light flashing on the dash when I first turn the key.
     

Products Discussed in

To Top