1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Brake Assist (EBD) Issue

Discussion in '4th Gen 4Runners (2003-2009)' started by kaidoy888, Nov 16, 2022.

  1. Nov 16, 2022 at 9:28 AM
    #1
    kaidoy888

    kaidoy888 [OP] New Member

    Joined:
    Sep 17, 2021
    Member:
    #23387
    Messages:
    2
    Gender:
    Male
    First Name:
    Richie
    Vehicle:
    2005 SR5
    18" AR Rims, LED lighting all around.
    2005 SR5, 4WD.
    I recently upgraded my front brakes to 13.3" rotors, so I replaced the dust shields, rotors and calipers and manually bled the brakes. No problem braking, but the skid light, VSC OFF, VSC TRAC, and ABS lights came on. I did a Zero Point Calibration and an ABS light reset, and while I have no dash lights up, the brake assist randomly kicks in when braking, either lightly or firmly. My mechanic used and ABS reader and didn't find any issues or codes. Real-time wheel speed is okay, so no sensor or sensor ring issues. Had to disconnect the fron ABS sensors to deliberately fail the sysytem so I can stop normally.I can't find anything online about the barake assist, a.k.a. Electronic Brakeforce Distribution or EBD. Anyone else have this issue?
     

Products Discussed in

To Top