1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Both 4Runners hesitate after start.

Discussion in '3rd Gen 4Runners (1996-2002)' started by HunterGreen01, Nov 23, 2016.

  1. Nov 23, 2016 at 9:59 AM
    #1
    HunterGreen01

    HunterGreen01 [OP] New Member

    Joined:
    Nov 23, 2016
    Member:
    #3073
    Messages:
    3
    Gender:
    Male
    First Name:
    Ryan
    San Antonio, Texas
    Vehicle:
    2001 Hunter Green SR5
    2014 SR5 wheels, brush guard, roof rack
    My 1999 4cyl has a very noticeable stutter or uneven acceleration while it warms up. Not a misfire(I think). My 2001 v6 does the same thing but not as bad. I was reading another forum and a guy said that his did this and his transmission ultimately went out. Now I'm kind of scared. I haven't checked the quality of the transmission fluid recently but I am pretty sure they have plenty of it. Also, the 1999 has a check engine light that turns on and off that seems to correlate to the weird accceleration. I haven't been able to check that code since I bought it. Every time I try it clears itself before I get there. Also, the 2.7 seems to be getting around 10 miles a gallon. Are the gas tanks the same size?
     
  2. Nov 23, 2016 at 10:21 PM
    #2
    HunterGreen01

    HunterGreen01 [OP] New Member

    Joined:
    Nov 23, 2016
    Member:
    #3073
    Messages:
    3
    Gender:
    Male
    First Name:
    Ryan
    San Antonio, Texas
    Vehicle:
    2001 Hunter Green SR5
    2014 SR5 wheels, brush guard, roof rack
    Update. The transmission fluid is fine. Maybe a little too full. And the code is P0402. So some sort of EGR issue. Before I spend 150 dollars on a valve, does anyone have a suggestion?
     
  3. Nov 25, 2016 at 10:16 AM
    #3
    Bob

    Bob Member Staff Member

    Joined:
    Apr 3, 2014
    Member:
    #1
    Messages:
    1,808
    First Name:
    Bob
    SoCal
    Sub'd for answers
     
  4. Dec 11, 2016 at 7:23 PM
    #4
    Sharkpilot

    Sharkpilot New Member

    Joined:
    Dec 9, 2016
    Member:
    #3161
    Messages:
    14
    Gender:
    Male
    First Name:
    Patrick
    Vehicle:
    2002 4Runner SR5 Sport
    None
    I'm pretty new to the vehicle (3 days), but have you done a solid once over on all of the vacuum lines? My second day driving mine the tuck almost shut down at idle and I got check engine lights. Turns out I accidentally knocked off the PCV bleed line when sucking acorns out of the top of the engine. Popped the line back in and all is well with the world. This is simple I know, but vacuum leaks have created issues in the past with other cars I've owned. Check condition of lines too. If they are cracked on the underside you won't see it and it will be leaking. Actually feel the lines.
     
    4runner52 likes this.
  5. Dec 12, 2016 at 3:17 PM
    #5
    4runner52

    4runner52 New Member

    Joined:
    Dec 7, 2016
    Member:
    #3151
    Messages:
    50
    Gender:
    Male
    First Name:
    Trevor
    West Slope, CO
    Vehicle:
    1999 4runner
    Toytec Ultimate Lift Spidertrax 285 Duratracs Custom Armor 22" lightbar Cobra 19 CB Other Shenanigans
    "P0402 - Exhaust Gas Recirculation Flow Excessive Detected"

    The EGR temp sensor detected that the EGR was allowing too much exhaust into the intake. This would be like a large vacuum leak, causing motor to run rough. Check all your vacuum lines for leaks on the 2.7 first. If there is a leak that's a potential source of the problem.
     
  6. Dec 14, 2016 at 10:58 AM
    #6
    ramonortiz55

    ramonortiz55 New Member

    Joined:
    May 3, 2015
    Member:
    #590
    Messages:
    1,663
    Gender:
    Male
    First Name:
    Ramon
    Vehicle:
    2001 4runner limited silver millenium
    was this ever resolved?
     

Products Discussed in

To Top