1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

4Runner Engine whine

Discussion in '5th Gen 4Runners (2010+)' started by 4StunnerSrq, Jun 26, 2020.

  1. Jun 26, 2020 at 4:58 PM
    #1
    4StunnerSrq

    4StunnerSrq [OP] New Member

    Joined:
    Sep 17, 2018
    Member:
    #7162
    Messages:
    53
    Gender:
    Male
    First Name:
    Mike
    Vehicle:
    2013 4Runner SR5
    Led swapped everything, custom Truck vault Sliding drawers, 5% Tint all the way around, 3 Inch lift kit
    Hey guys, so recently my 2013 4Runner Has developed a engine whine, the noise resembles the sound of a super charger “which it does not have” and I brought it to Toyota and they said the noise is completely normal. I test drove a 2018-2019 today and didn’t hear the noise in the newer models. Has anyone come across this issue? And if so what did you do to fix it? I’ve been told it can be the Oil Pump which I’m hoping it’s not. But what I will be doing is replacing the Ilder Pullys & the SERP Belt this weekend to see if that corrects the issue. Any help will be appreciated!
    Thanks!
    2013 4Runner 125,000K miles
     
  2. Jun 28, 2020 at 4:32 AM
    #2
    captsolo

    captsolo New Member

    Joined:
    Jun 2, 2019
    Member:
    #10131
    Messages:
    167
    Gender:
    Male
    First Name:
    Tom
    nassau bahamas
    Vehicle:
    2005 SR5
    I have some whine noise in my 2005 SR5 V6 with 150,000 miles. Doubt it is your oil pump. Do you get check engine oil lite or Codes?

    I've been watching mine for over a year and there is no change, and could be normal wear. My whine is there at all speeds. Transmission shift like new.

    30,000 miles ago I had the dealer do a 5 quart D/F of the tranny.

    I've never had a check engine lite or a code in my 2005 in the 15 years that I've owned it.

    If you are driving at 30 mph and you shift into neutral, does the whine go away. If it does it is somewhere in your drive train and not the engine. Look carefully at everything mechanical that runs on the serpentine belt - alternator, water pump, AC compressor for noise, but don't just replace anything.
     
    Last edited: Jun 29, 2020
  3. Jun 28, 2020 at 7:35 AM
    #3
    Thatbassguy

    Thatbassguy New member? Really??

    Joined:
    Mar 27, 2019
    Member:
    #9314
    Messages:
    2,235
    Gender:
    Male
    First Name:
    James
    S/E Wisconsin
    Vehicle:
    2019 TRDORP, KDSS, MGM
    RSG sliders, Yakima offgrid basket, Pro-Comp wheels, SOS Streamline bumper and skids, Warn VR EVO10S winch + Ultimate Sidewinder, Bilstein 6112 + 5100 + rear lift coils, Rigid Dually SS ditch lights w/Caliraised brackets and OEM style dash switch
    It it possible to post a video of the noise?

    My '19 makes a slight whining noise at moderate acceleration. It has done it since new, though.
     
  4. Jun 28, 2020 at 12:40 PM
    #4
    Oldtoyotaguy

    Oldtoyotaguy New Member

    Joined:
    Sep 21, 2018
    Member:
    #7224
    Messages:
    721
    Gender:
    Male
    Vehicle:
    2018 Toyota 4 Runner Offroad
    My 2018 ORP is dead quiet. I have to check the tach to see if it’s a running, although wide open passing someone going uphill, which I hardly ever do, it has a throaty roar.
     

Products Discussed in

To Top