1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

3.0L engine turns over but no start

Discussion in '2nd Gen 4Runners (1990-1995)' started by ridingmike, Aug 13, 2016.

  1. Aug 13, 2016 at 9:39 PM
    #1
    ridingmike

    ridingmike [OP] New Member

    Joined:
    Aug 13, 2016
    Member:
    #2460
    Messages:
    4
    Gender:
    Male
    First Name:
    Michel
    Vehicle:
    94 4runner V6 5 speed
    Hi everyone, I am new at this and I need advice. My 94 4runner does not run but it turns over good, it has spark, tested fuel pressure at 44 psi, checked the timing marks of the cam belt OK, changed the fuel injectors for the new 6 holes model, compression is good, I gave a shot of ether and it did not even kick or try to start. And if I pull it it will start! Any advice to what could be wrong here?
     
  2. Aug 18, 2016 at 7:35 AM
    #2
    Kyle11863

    Kyle11863 King of the BS

    Joined:
    Jul 28, 2015
    Member:
    #807
    Messages:
    202
    Gender:
    Male
    First Name:
    Kyle
    Big Bear California
    Vehicle:
    1990 Toyota 4Runner SR5 V6 5 Speed Manual
    Doug Thorley long tube headers and lots of mud
    Maybe the idle needs to be adjusted a little higher? :notsure:
     
  3. Aug 23, 2016 at 7:12 AM
    #3
    ridingmike

    ridingmike [OP] New Member

    Joined:
    Aug 13, 2016
    Member:
    #2460
    Messages:
    4
    Gender:
    Male
    First Name:
    Michel
    Vehicle:
    94 4runner V6 5 speed
    Hi Kyle11863,
    Good idea, but last time I pulled started it, I let it idle to warm up for 45 minutes or so, turned it off then started it warm: turned over well but no start again ? When it turn over it doesn't even try, I am puzzled and getting desperate to find a fix. How do you adjust the idle speed?
     
  4. Oct 27, 2016 at 9:36 AM
    #4
    ridingmike

    ridingmike [OP] New Member

    Joined:
    Aug 13, 2016
    Member:
    #2460
    Messages:
    4
    Gender:
    Male
    First Name:
    Michel
    Vehicle:
    94 4runner V6 5 speed
    Hi every one, got the problem fixed, I send it to an electrical shop to find that the ignition coil was weak! Now it start up good.
    Thanks for the advice. Michel
     
    Bob likes this.

Products Discussed in

To Top