1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2020 4Runner SR5P Carplay Issue

Discussion in '5th Gen 4Runners (2010+)' started by ant the ninja, Oct 14, 2019.

  1. Jan 6, 2020 at 12:47 PM
    #121
    winback82

    winback82 New Member

    Joined:
    Jan 6, 2020
    Member:
    #12589
    Messages:
    13
    Gender:
    Male
    First Name:
    Aman
    Vehicle:
    2020 TRD PRO WHITE
    Just got a call from the dealer. They spoke to the engineers. Nothing really new...according to them its a known issue with the software in the iPhone. Just have to wait until Apple releases new software.
     
  2. Jan 6, 2020 at 2:06 PM
    #122
    Drababan

    Drababan New Member

    Joined:
    Dec 2, 2019
    Member:
    #12190
    Messages:
    90
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5 Premium
    Yeah, I wouldn't accept that at all. We know for sure that isn't the case. The phone works just fine on other vehicles including the 4Runner. My Service Manager worked with Toyota Engineering and showed them all the evidence and they told him to replace the head unit. I would go back and test multiple vehicles on the lot with your phone and cable and show them it's the head unit in the 4Runner, not the phone. I can tell you for sure the next Apple update doesn't fix it. I'm already using the beta of 13.3.1.
     
  3. Jan 6, 2020 at 6:03 PM
    #123
    winback82

    winback82 New Member

    Joined:
    Jan 6, 2020
    Member:
    #12589
    Messages:
    13
    Gender:
    Male
    First Name:
    Aman
    Vehicle:
    2020 TRD PRO WHITE
    Did replacing the radio fix the issue for you? We tested another 4Runner on the lot and it was having the same issue.
     
  4. Jan 7, 2020 at 4:19 AM
    #124
    Drababan

    Drababan New Member

    Joined:
    Dec 2, 2019
    Member:
    #12190
    Messages:
    90
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5 Premium
    I'm waiting for it to come in. If you scroll back you'll see all the testing that was done at the dealership. The first 2 vehicles we tried (SR5-P and Limited) both worked without issues.

    We know it's not a phone issue because the iPhone 11 works on a bunch of other vehicles. Works fine in my wife's car that has a several years old Kenwood head unit that support CarPlay. Other say works fine in Jeep, VW, and others (read through the thread).
     
  5. Jan 7, 2020 at 10:20 AM
    #125
    RusPro17

    RusPro17 New Member

    Joined:
    Sep 26, 2017
    Member:
    #4821
    Messages:
    351
    Gender:
    Male
    First Name:
    Don
    Pa.
    Vehicle:
    2020 TRD Pro
    Comparing my 17 Pro ride with the bilsteins and my 2020 Pro with the fox suspension i think the fox suspension has a softer ride. I like how my 2020 Pro rides. I may down the road throw on the Cornfed spacer lift. It won’t effect the ride much.
     
  6. Jan 7, 2020 at 10:43 AM
    #126
    winback82

    winback82 New Member

    Joined:
    Jan 6, 2020
    Member:
    #12589
    Messages:
    13
    Gender:
    Male
    First Name:
    Aman
    Vehicle:
    2020 TRD PRO WHITE
    Let me know if that fixes the issue for you.

    We tired a 4Runner that was sitting on the lot and it was having the same issue. I agree with you, that phone is not the issue. My wife has a Mazda and we have no issues with the phone is her car. Toyota and Apple have to work together and come up with a solution. I have a case open with Toyota and Apple.
     
  7. Jan 7, 2020 at 12:40 PM
    #127
    Run4it

    Run4it New Member

    Joined:
    Oct 2, 2019
    Member:
    #11519
    Messages:
    10
    Gender:
    Male
    Vehicle:
    2020 TRD Off Road 4Runner
    I have an 8plus and I have issues and it's F'd!!! WAZE app craps out and audio from phone streaming issues. Also experience slow AF response sometimes. hmm What else?
    This is the only issue or complaint I have with my new '20 ORP. God I love this vehicle!!
     
  8. Jan 7, 2020 at 12:46 PM
    #128
    Drababan

    Drababan New Member

    Joined:
    Dec 2, 2019
    Member:
    #12190
    Messages:
    90
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5 Premium
    You might want to try simple stuff like making sure you are using a good cable and perhaps resetting your phone settings. I don't think anyone here is having issues other than with making phone calls with the iPhone via CarPlay. Everything else works fine for us.
     
    ant the ninja [OP] and winback82 like this.
  9. Jan 7, 2020 at 4:22 PM
    #129
    ant the ninja

    ant the ninja [OP] New Member

    Joined:
    Oct 9, 2019
    Member:
    #11604
    Messages:
    61
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5P
    Exactly. It seems to only be affecting the phone calls portion. Everything else works fine.

    Do you notice your phone gets very warm when plugged in and doesn’t really charge that much? I have a 2020 Grand Cherokee that car play works perfect in with my phone and it charges no problem but with the 4Runner I find it doesn’t charge, it just heats the phone up.
     
  10. Jan 8, 2020 at 11:56 AM
    #130
    Drababan

    Drababan New Member

    Joined:
    Dec 2, 2019
    Member:
    #12190
    Messages:
    90
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5 Premium
    Got a note from the dealership today that a brand new (not remanufactured) head until is expected to arrive on the 11th. Hopefully I'll have a fully functioning car by next week! I'll be sure to post up status when it's installed.
     
    Motorjock721 likes this.
  11. Jan 8, 2020 at 2:11 PM
    #131
    winback82

    winback82 New Member

    Joined:
    Jan 6, 2020
    Member:
    #12589
    Messages:
    13
    Gender:
    Male
    First Name:
    Aman
    Vehicle:
    2020 TRD PRO WHITE
    Nice! Keep us posted. Really curious to see if that fixes the issue. Fingers crossed!

    I did get a call from Toyota after opening a case yesterday. According to them, its a known issue and they are working with Apple to find a solution. There is no ETA at this point.

    Has anyone take can further steps? Not sure where to go from here.
     
  12. Jan 8, 2020 at 7:32 PM
    #132
    ant the ninja

    ant the ninja [OP] New Member

    Joined:
    Oct 9, 2019
    Member:
    #11604
    Messages:
    61
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5P
    I hope this does fix it but I guess my question is, which software version will be shipped on it? Would they even know before installing it? Because if it’s any other one than 1021, then it should have the same behavior, at least that’s what we can assume, right?

    Either way Apple is aware of this issue and they have fully acknowledged it exists without putting the blame on Toyota or themselves. They keep saying they are working together closely with the Toyota engineers on a resolve and the case is still active and ongoing. The original timeline I was given was it would be fixed BY the new year...well that’s come and gone.

    It just boggles my mind that these two multi-billion dollar companies can’t figure something this simple out.
     
    Last edited: Jan 8, 2020
  13. Jan 8, 2020 at 7:48 PM
    #133
    winback82

    winback82 New Member

    Joined:
    Jan 6, 2020
    Member:
    #12589
    Messages:
    13
    Gender:
    Male
    First Name:
    Aman
    Vehicle:
    2020 TRD PRO WHITE
    Mine had 1021 on it and I was having issues. Couple days ago they did an update to 1035 and I still have issues.
     
  14. Jan 8, 2020 at 8:00 PM
    #134
    ant the ninja

    ant the ninja [OP] New Member

    Joined:
    Oct 9, 2019
    Member:
    #11604
    Messages:
    61
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5P
    I have 1006 on mine and it doesn’t work. I very much hope that this is just an issue with the headunits but I don’t believe it fully is. I think this is rooted in the iPhone 11/11 Pros software or chipset specifically somehow, it just doesn’t add up but the only variable is the phone itself.

    If it is Apples software then technically no iPhones should work on the radio but since other iPhones work fine, then it has to be Toyota’s issue....but at the same time, the 11/11 Pro work fine in virtually every other system I’ve tested (Range Rover, Jeep, Volvo, Kia, Hyundai). Which is why unfortunately I really think the actual fix will need to come from Apple.

    Truthfully I don’t care where the fix comes from, just as long as one comes. This should not be an issue that is taking this long to fix, both company’s are dragging their feet here
     
  15. Jan 9, 2020 at 4:50 AM
    #135
    Drababan

    Drababan New Member

    Joined:
    Dec 2, 2019
    Member:
    #12190
    Messages:
    90
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5 Premium

    We shall see. Personally, i'm not sure it's a software issue at all anymore. We all have varying versions and some work, some don't, all with different phones. Could be the head unit, could be a number of other things. I'm not willing to wait around and pay for functionality that i'm not able to use though.

    As someone who works as a Systems Engineer at a major software company, I can tell you that, "we are aware and working on it" is code for not doing anything. If that truly were the case Toyota Engineering and Toyota Multi-Media managers would at least know about the issue and would be pushing all these cases together for a resolution. Right now, they aren't. That statement is from some low level customer service person at Apple that has no other answer to give you and is pushing you off. They are able to confirm your phone works on other non-4Runner CarPlay enabled head units. How could it possibly be their software? They are the publisher of the standard and they program to it. It is the responsibility of the radio manufactures and their software (written by Panasonic for Toyota) to write their code in compliance. It it were an Apple hardware or software issue it would be cross platform and they would take it seriously.
     
  16. Jan 9, 2020 at 3:01 PM
    #136
    SilverVenture2020

    SilverVenture2020 New Member

    Joined:
    Jan 9, 2020
    Member:
    #12631
    Messages:
    1
    Gender:
    Male
    First Name:
    Frank
    Vehicle:
    2020 Venture
    I have the same issue with my iPhone 11 Pro. Looking forward to the fix.
     
  17. Jan 13, 2020 at 10:31 AM
    #137
    winback82

    winback82 New Member

    Joined:
    Jan 6, 2020
    Member:
    #12589
    Messages:
    13
    Gender:
    Male
    First Name:
    Aman
    Vehicle:
    2020 TRD PRO WHITE
    Anyone heard anything new? Any update?
    I got a call from Apple, they had me try a few things, but no luck. This is getting very frustrating and taking way to long to find a fix, if even there I a fix.
     
  18. Jan 13, 2020 at 11:42 AM
    #138
    DryHeatAZ

    DryHeatAZ New Member

    Joined:
    Jan 13, 2020
    Member:
    #12700
    Messages:
    4
    Gender:
    Male
    Mesa AZ
    Vehicle:
    2020 Super White ORP
    2020 and iPhone 11

    I've contacted Toyota about this issue as well. I have an appointment with the dealership to document the problems I am having with both Carplay and Bluetooth. Bluetooth echo on the recipient end is frustrating, and I've tried every fix.. unparing, BT volume all the way up, all the way down, phone in pocket, etc. Nothing so far fixes the echo. Now I just read there's a class action lawsuit against Toyota for this issue.

    Apple Carplay phone audio is so choppy and cuts in and out that you cannot have a phone conversation. Maps and audio work great but forget about using it to make hands-free calls.

    As of today, I have no way of utilizing either option for hands-free calling which is completely unsafe and unacceptable not to mention against the law to have a phone up to my ear while driving.
     
  19. Jan 13, 2020 at 11:50 AM
    #139
    RusPro17

    RusPro17 New Member

    Joined:
    Sep 26, 2017
    Member:
    #4821
    Messages:
    351
    Gender:
    Male
    First Name:
    Don
    Pa.
    Vehicle:
    2020 TRD Pro
    I’m not sure if someone has a answer for this. What I’m reading here is all about the new iPhone 11 correct. If you have a older iPhone like the 7plus or 8plus are they running on the same software that the 11 has. If it is I would think it’s something in the new phone causing the issue with the calls that’s not connecting correctly with the Toyota Headunit. Any info.
     
  20. Jan 13, 2020 at 1:15 PM
    #140
    Drababan

    Drababan New Member

    Joined:
    Dec 2, 2019
    Member:
    #12190
    Messages:
    90
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5 Premium
    My new head unit was supposed to land at the dealer today. Hopefully I can get it installed this week and will update this thread with the results
     
    ant the ninja [OP] and SlvrSlug like this.
  21. Jan 13, 2020 at 6:17 PM
    #141
    4Runner_Patrick

    4Runner_Patrick New Member

    Joined:
    Aug 24, 2016
    Member:
    #2541
    Messages:
    108
    Gender:
    Male
    Vehicle:
    2016 4Runner SR5 Premium Silver
    A member reported his X works. I am waiting to hear from @Drababan new head result before I test mine out.
     
    Motorjock721 likes this.
  22. Jan 13, 2020 at 6:20 PM
    #142
    ant the ninja

    ant the ninja [OP] New Member

    Joined:
    Oct 9, 2019
    Member:
    #11604
    Messages:
    61
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5P
    looking forward to the results!! God I hope this is the fix.
     
  23. Jan 13, 2020 at 7:41 PM
    #143
    winback82

    winback82 New Member

    Joined:
    Jan 6, 2020
    Member:
    #12589
    Messages:
    13
    Gender:
    Male
    First Name:
    Aman
    Vehicle:
    2020 TRD PRO WHITE
    Is this something you can file a lemon case for? Has anyone gone down that road?
     
  24. Jan 14, 2020 at 5:44 AM
    #144
    Rocket_Pilot

    Rocket_Pilot New Member

    Joined:
    Oct 27, 2019
    Member:
    #11803
    Messages:
    18
    I have an iPhone 8 Plus and have this issue as well. It's not just a new phone issue. At least based on my experience. I can't make phone calls while using GPS without everything going haywire.
     
  25. Jan 14, 2020 at 6:01 AM
    #145
    RusPro17

    RusPro17 New Member

    Joined:
    Sep 26, 2017
    Member:
    #4821
    Messages:
    351
    Gender:
    Male
    First Name:
    Don
    Pa.
    Vehicle:
    2020 TRD Pro
    Don’t make sense I have the iPhone 7 Plus and 2020 Pro no issues. Do you have built in GPS in your Toyota or you using your Apple car play on your phone for your maps with gps.
     
  26. Jan 14, 2020 at 9:06 AM
    #146
    Drababan

    Drababan New Member

    Joined:
    Dec 2, 2019
    Member:
    #12190
    Messages:
    90
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5 Premium
    Working on it. In Maryland they get 4 chances to fix the issue. Yes, anything that impacts usability or resale can be used for the lemon law. I spend a ton of time in the car on conference calls and this severely impacts the usability of the vehicle for me.
     
  27. Jan 14, 2020 at 9:08 AM
    #147
    Drababan

    Drababan New Member

    Joined:
    Dec 2, 2019
    Member:
    #12190
    Messages:
    90
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5 Premium
    Have you tried a newer phone in your car? I worked with the dealer and my iPhone 11 worked in two other brand new 4Runners on the lot. You car just might work period and have nothing to do with the model phone you have.
     
  28. Jan 14, 2020 at 9:08 AM
    #148
    Drababan

    Drababan New Member

    Joined:
    Dec 2, 2019
    Member:
    #12190
    Messages:
    90
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5 Premium
    Got news this morning that my head unit didn't show up yesterday and the new ETA is the 15th (Weds). The wait continues.
     
  29. Jan 14, 2020 at 12:51 PM
    #149
    Drababan

    Drababan New Member

    Joined:
    Dec 2, 2019
    Member:
    #12190
    Messages:
    90
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5 Premium
    Ladies and Gentlemen, boys and girls, i'm please to announce WE HAVE A SOLUTION!!!!!!!!!

    So I got a text from the dealer Service Manager with the following.

    [​IMG]
    [​IMG]

    Thats right! New software and this time it FIXES THE ISSUE. I rushed over and got it done, took about 8 minutes and IT F#$%ING WORKS! I hope all of you that have been waiting patiently have the same success that I do. Enjoy your fully functioning CarPlay!
     
  30. Jan 14, 2020 at 1:12 PM
    #150
    DryHeatAZ

    DryHeatAZ New Member

    Joined:
    Jan 13, 2020
    Member:
    #12700
    Messages:
    4
    Gender:
    Male
    Mesa AZ
    Vehicle:
    2020 Super White ORP
    YESSS!!!! I have an appointment with the dealer tomorrow!
     

Products Discussed in

To Top