1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2020 4Runner SR5P Carplay Issue. UPDATE: Fixed with iOS 13.3.1 or Toyotas Entune Update

Discussion in '5th Gen 4Runners (2010+)' started by ant the ninja, Oct 14, 2019.

  1. Jan 25, 2020 at 5:13 PM
    #211
    The_Reaper

    The_Reaper New Member

    Joined:
    Jan 25, 2020
    Member:
    #12881
    Messages:
    1
    Gender:
    Male
    Vehicle:
    2020 TRD ORP

    Thank you, that worked perfectly. TeamHeq pointed me here from T4R and now I'm a member :).

    I did not disconnect the battery, just ran the update and followed davidgasparyan's readme file.

    Screenshots for those who haven't done it yet.

    20200125_173622.jpg 20200125_173645.jpg 20200125_173659.jpg 20200125_173709.jpg 20200125_174008.jpg 20200125_174240.jpg 20200125_174409.jpg
     
    Last edited: Jan 25, 2020
    davidgasparyan likes this.
  2. Jan 25, 2020 at 9:59 PM
    #212
    semp

    semp New Member

    Joined:
    Sep 4, 2018
    Member:
    #7001
    Messages:
    13
    Gender:
    Male
    Anyone with iphone 11 Pro/max working fine?
    Mine works with ignition on once every 5 attempts but only once with the vehicle on.
    The rest of the time im only getting the not supported accessory message in my phone.
     
  3. Jan 26, 2020 at 6:58 AM
    #213
    davidgasparyan

    davidgasparyan New Member

    Joined:
    Jan 19, 2020
    Member:
    #12795
    Messages:
    10
    Gender:
    Male
    First Name:
    David
    Vehicle:
    2020 TRD ORP
    What cable you using?
     
  4. Jan 26, 2020 at 7:03 AM
    #214
    semp

    semp New Member

    Joined:
    Sep 4, 2018
    Member:
    #7001
    Messages:
    13
    Gender:
    Male
    Tried 5 different cable including a new one purchased from Apple.
     
  5. Jan 26, 2020 at 7:05 AM
    #215
    davidgasparyan

    davidgasparyan New Member

    Joined:
    Jan 19, 2020
    Member:
    #12795
    Messages:
    10
    Gender:
    Male
    First Name:
    David
    Vehicle:
    2020 TRD ORP
    Ok. I had issues when I was plugging my phone before system loads completely. Doesnt say accessory bot supported, it wasnt showing my phone at all. But once system loaded then plugging phone it works fine
     
  6. Jan 26, 2020 at 11:19 AM
    #216
    JDSTONE

    JDSTONE New Member

    Joined:
    Sep 20, 2019
    Member:
    #11354
    Messages:
    9
    Gender:
    Male
    First Name:
    Jason
    Vehicle:
    2020 TRD Pro Runner

    Did you use the Audio Plus or Premium Audio files?
     
  7. Jan 26, 2020 at 4:31 PM
    #217
    semp

    semp New Member

    Joined:
    Sep 4, 2018
    Member:
    #7001
    Messages:
    13
    Gender:
    Male
    Yeah, this did not work for me.

    Also tested with an iphone 8 and 8 plus with no success, I still have the not supported accessory message in every phone.
     
  8. Jan 26, 2020 at 6:31 PM
    #218
    heq206

    heq206 New Member

    Joined:
    Dec 31, 2018
    Member:
    #8270
    Messages:
    19
    Seattle, WA
    Vehicle:
    2020 4Runner TRD Pro Army Green
    I used the Premium Audio. I have the TRD Pro which has Premium Audio.
     
    Last edited: Jan 27, 2020
  9. Jan 27, 2020 at 4:51 AM
    #219
    SilverVenture2020

    SilverVenture2020 New Member

    Joined:
    Jan 9, 2020
    Member:
    #12631
    Messages:
    2
    Gender:
    Male
    First Name:
    Frank
    Vehicle:
    2020 Venture
    Used the files provided (Thanks!) and so far the iPhone 11 Pro sound issue is fixed. Will continue to monitor...
     
  10. Jan 28, 2020 at 10:03 AM
    #220
    ant the ninja

    ant the ninja [OP] New Member

    Joined:
    Oct 9, 2019
    Member:
    #11604
    Messages:
    69
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5P
    I got a call from the contact at Apple yesterday that told me that the new software update, 13.3.1 will fix the issue. When I told her Toyota had already released an update she had no idea about it, not surprised. I just got the update and I see in change logs it mentions a fix for carplay.

    Eitherway, I'm glad the issue seems to be resolved!

     
  11. Jan 28, 2020 at 10:14 AM
    #221
    winback82

    winback82 New Member

    Joined:
    Jan 6, 2020
    Member:
    #12589
    Messages:
    14
    Gender:
    Male
    First Name:
    Aman
    Vehicle:
    2020 TRD PRO WHITE
    Apple just released 13.3.1.
    • Addresses a CarPlay issue that could cause distorted sound when making phone calls in certain vehicles
     
  12. Jan 29, 2020 at 1:31 AM
    #222
    JxSmoov

    JxSmoov New Member

    Joined:
    Jan 29, 2020
    Member:
    #12927
    Messages:
    1
    Gender:
    Male
    First Name:
    J
    Vehicle:
    2020 $runner SR5P
    Motorjock721 likes this.
  13. Jan 29, 2020 at 5:39 AM
    #223
    ant the ninja

    ant the ninja [OP] New Member

    Joined:
    Oct 9, 2019
    Member:
    #11604
    Messages:
    69
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5P
    UPDATE: This has been resolved. Toyota released an update for their radio that you need to go to the dealer for or download the files posted in this thread to update yourself.

    Apple has also released 13.3.1 which includes the fix for CarPlay as well.

    Thank you to everyone who continued to email and call Apple and Toyota, it looks like we were able to get it fixed!

    Huge thank you to @davidgasparyan for posting the update files as well!
     
    Motorjock721 and SlvrSlug like this.
  14. Jan 29, 2020 at 11:47 AM
    #224
    atx-4runner

    atx-4runner New Member

    Joined:
    Jan 17, 2020
    Member:
    #12764
    Messages:
    2
    Gender:
    Male
    Vehicle:
    2020 4Runner TRD Pro
    I applied the latest Apple update and it appears to have fixed this issue on my 2020 TRD Pro 4Runner.

    I’m going to test a bit more today before canceling my service appointment to have them update my radio.
     
  15. Jan 29, 2020 at 1:24 PM
    #225
    Matt14ky

    Matt14ky New Member

    Joined:
    Nov 17, 2019
    Member:
    #12021
    Messages:
    4
    Gender:
    Male
    First Name:
    Matt
    Vehicle:
    2020 Toyota 4Runner nightshade
    David. Is the fix that you have now the 1040 update and the 13.3.1 Apple update? Or are those files something different? I have done the Toyota update and the Apple update now, still have the same issues.
     
  16. Jan 30, 2020 at 7:42 AM
    #226
    SlvrSlug

    SlvrSlug New Member

    Joined:
    Jun 3, 2018
    Member:
    #6172
    Messages:
    3,227
    Gender:
    Male
    First Name:
    John
    San Diego, Ca.
    Vehicle:
    2017 4-Runner SR-5
    Slightly modded
    I think some of the members had good luck with the 1047 update.
     
  17. Jan 30, 2020 at 8:58 AM
    #227
    semp

    semp New Member

    Joined:
    Sep 4, 2018
    Member:
    #7001
    Messages:
    13
    Gender:
    Male
    My car is at the dealer since tuesday.
    I am starting to think that I have a hardware problem other than software.

    With all updates available (phone and head unit), I still get the not supported accessory flashing on my phone (and other iphone versions) and no apple car play at all.
     
    4Runnin4fun likes this.
  18. Jan 30, 2020 at 6:29 PM
    #228
    Stuartjp70

    Stuartjp70 New Member

    Joined:
    Jan 30, 2020
    Member:
    #12960
    Messages:
    1
    Gender:
    Male
    First Name:
    Stuart
    Gonzales, LA
    Vehicle:
    2020 White 4Runner SR5 Premium
    Factory “Black Out” package
    I purchased my 2020 SR5 Premium this month and have had call issues using the iPhone 11 Pro Max as well. Updated my iOS to 13.3.1 today and it appears to have resolved the issue. I will update the forum if something changes.
     
  19. Jan 31, 2020 at 5:45 AM
    #229
    eggcouncil

    eggcouncil New Member

    Joined:
    Dec 8, 2019
    Member:
    #12245
    Messages:
    9
    Gender:
    Male
    Vehicle:
    2020 TRD Off-Road Premium w/KDSS
    RSG angled rock sliders; Goodyear Wrangler All-Terrain Adventure With Kevlar
    Hmm...I tried 13.3.1 today without the car upgrade (running at 1007 audio) on a 2020 Off-Road Premium, and it is...better, but not sure if it is fully resolved. The audio quality is MUCH improved, and the phone user interface is better, most of the time, but on one interaction, I found it to have the same sluggish behavior as before the 13.3.1 upgrade. We shall see...I'll get the car updated at some point too.
     
  20. Feb 3, 2020 at 5:31 PM
    #230
    4Runnin4fun

    4Runnin4fun New Member

    Joined:
    Feb 2, 2020
    Member:
    #12999
    Messages:
    7
    Gender:
    Female
    Vehicle:
    2020 4Runner TRD
    Posted a new thread w it h similar issues to these but thought I’d touch base here as well, my car is two months old and two days ago CarPlay completely took a dive on me I plug my phone in and it intermittently charges and stops charging and doesn’t even pop up with any option to select car play , went to the dealer they upgraded to 1021 on audio and Nav 1006 , sat here for three hours , they said it was fixed and nooooooooo dice , now waiting in the service area while a tech is trying to further trouble shoot
     
  21. Feb 3, 2020 at 5:32 PM
    #231
    ant the ninja

    ant the ninja [OP] New Member

    Joined:
    Oct 9, 2019
    Member:
    #11604
    Messages:
    69
    Gender:
    Male
    Vehicle:
    2020 4Runner SR5P
    Have them upgrade the radio to 1047 and 1030 and see if that fixes it
     
    4Runnin4fun and SlvrSlug like this.
  22. Feb 3, 2020 at 5:54 PM
    #232
    4Runnin4fun

    4Runnin4fun New Member

    Joined:
    Feb 2, 2020
    Member:
    #12999
    Messages:
    7
    Gender:
    Female
    Vehicle:
    2020 4Runner TRD
    They tried to do further updates with a usb drive , and my USB port wouldn’t even detect the drive that was plugged in ! What a nightmare , they are ordering a replacement drive and it will be installed Wednesday .
     
  23. Feb 7, 2020 at 9:26 PM
    #233
    semp

    semp New Member

    Joined:
    Sep 4, 2018
    Member:
    #7001
    Messages:
    13
    Gender:
    Male
    Quick update to help those who have the same “unique” issue that I have.

    So far its been me and user Deanna here.

    Problem:

    - Apple car play won’t connect
    - Accessory not supported flashing non stop at the phone

    My dealer swapped my head unit which was considered defective.
    Best way to have this fixed was contacting Toyota headquarters and opening a case. Then they will contact the dealer and “push” them to fix your car. After all troubleshoot with no success, Toyota approved and a new head units was ordered and swapped today.

    Apple car play works flawless now and happy that this chapter is over.
     
  24. Feb 8, 2020 at 12:47 PM
    #234
    4Runnin4fun

    4Runnin4fun New Member

    Joined:
    Feb 2, 2020
    Member:
    #12999
    Messages:
    7
    Gender:
    Female
    Vehicle:
    2020 4Runner TRD
    Good to know I’m not the only one with this situation !, that was the end result for myself as well , they ordered my headunit a couple days ago so I’m awaiting the switch . It’s horrible but I just hope this is a random defect and nothing more will cause me any problems , my 4Runner is under 4 months old and already had to have ( what I consider a major ) part replaced . I live in Orange County CA, and am
    Dealing with Tustin Toyota, they’ve been great so far , in case anyone on the thread has this issue and lives in the same area .
     
  25. Feb 17, 2020 at 9:25 AM
    #235
    4xColt

    4xColt New Member

    Joined:
    Feb 17, 2020
    Member:
    #13180
    Messages:
    1
    Gender:
    Male
    2020 Runner TRD Offroad Premium w/KDSS and Moonroof | RSG Sliders | TRD Pro Rims | BFG KO2s | Hikari Ultra (Low and High) | Focal IS 690
    Hey davidgasparyan,

    Just wanted to say "Thank you". I updated my system today and all is well.

    Thanks again
    Colt
     
  26. Feb 19, 2020 at 10:00 AM
    #236
    DallasTRDPro

    DallasTRDPro New Member

    Joined:
    Feb 7, 2020
    Member:
    #13058
    Messages:
    128
    Gender:
    Male
    Vehicle:
    2020 4 Runner TRD Pro
    I still don’t understand what’s so great about Apple CarPlay.
     
  27. Feb 19, 2020 at 1:02 PM
    #237
    CJT4Runner

    CJT4Runner New Member

    Joined:
    Jan 11, 2020
    Member:
    #12672
    Messages:
    109
    Gender:
    Male
    First Name:
    Chris
    Vehicle:
    ‘20 TRD ORP
    iOS apps are better than Toyota’s. Waze, Google Maps and Apple Maps don’t require a subscription. You have access to more music apps like Pandora. Being able to receive text messages and verbally respond with Siri is super nice. At least those are my reasons why I like Apple CarPlay.
     
  28. Feb 19, 2020 at 1:57 PM
    #238
    DallasTRDPro

    DallasTRDPro New Member

    Joined:
    Feb 7, 2020
    Member:
    #13058
    Messages:
    128
    Gender:
    Male
    Vehicle:
    2020 4 Runner TRD Pro
    I guess I'm not used to using it. Maybe one day I will give it a shot.
     
  29. Feb 25, 2020 at 12:20 AM
    #239
    HRDWRK

    HRDWRK New Member

    Joined:
    Feb 21, 2020
    Member:
    #13229
    Messages:
    7
    First Name:
    L.
    Vehicle:
    2019 Limited
    I'm have this same issue with a 2019 Limited with the premium audio!

    When my iPhone (with update 13.3.1)is linked by Bluetooth, the screen will go dead and restart! And continue to do so, until the BT on the phone is turned off!

    I took it to the dealer( Koons Toyota Westminster Md) and showed them the service bulletin!
    This all was after 3 other trips beforehand!

    They did a hard reboot! Disconnect the battery! But all the presets were still intact!!

    And then did a update! However it is not the same update number as this 2020 premium audio..

    (my screen doesn't look like the examples soon in others)

    The Service Manager advised me that it was the phones problem and there was NOTHING he could do or Toyota would do!

    I contacted the GM and he advised to contact Toyota and open a ticket!

    This is beyond my wildest thoughts that a $50k vehicle can not be used...

    Again is the 2019 premium audio the same as 2020?

    Beside the fact that this Toyota sm is a Richard knoggin, should I try another dealer?
     
  30. Feb 25, 2020 at 12:30 AM
    #240
    HRDWRK

    HRDWRK New Member

    Joined:
    Feb 21, 2020
    Member:
    #13229
    Messages:
    7
    First Name:
    L.
    Vehicle:
    2019 Limited
    Pic of head unit.

    20200221_122244.jpg
     

Products Discussed in

To Top