1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2004 4Runner 2UZ-FE fuel pressure issue

Discussion in '4th Gen 4Runners (2003-2009)' started by KCVIking406, Apr 10, 2020.

  1. Apr 10, 2020 at 11:47 AM
    #1
    KCVIking406

    KCVIking406 [OP] New Member

    Joined:
    Apr 1, 2020
    Member:
    #13712
    Messages:
    6
    Gender:
    Male
    First Name:
    Trevor
    Vehicle:
    2004 Limited 4Runner 4.7l
    Hey group!

    So I was able to figure out my last problem of not getting power to my fuel pump relay but now I am experiencing the following...

    1. I'm only getting 19psi out of the brand new fuel pump.

    2. As soon as I turn the vehicle off, the fuel pressure bleeds back into the tank immediately which in turn makes for long starts.

    I have replaced the following...

    Fuel pump
    Injectors
    Fuel damper

    Could my problem be a bad fuel pump regulator?

    Any advice would be greatly appreciated!

    Thanks!20200323_174840.jpg 20200323_174825.jpg 20200330_202606.jpg
     
  2. Jun 16, 2022 at 8:49 PM
    #2
    rowdsign

    rowdsign New Member

    Joined:
    Jun 16, 2022
    Member:
    #27494
    Messages:
    2
    The Regulator is on the pump assembly along with the filter. I have the same problem. Have you found a solution yet? I’m at a loss.
     
  3. Jun 17, 2022 at 7:24 AM
    #3
    negusm

    negusm New Member

    Joined:
    Oct 22, 2019
    Member:
    #11745
    Messages:
    1,120
    Gender:
    Male
    Vehicle:
    2002 4Runner SR5 4WD
    BionicRandy likes this.
  4. Jun 22, 2022 at 3:59 PM
    #4
    rowdsign

    rowdsign New Member

    Joined:
    Jun 16, 2022
    Member:
    #27494
    Messages:
    2
    So I believe I have found the culprit. Took the intake manifold off today and found that the intake manifold gasket had been split in half around one of the valves. Going to replace it tonight or tomorrow and see what happens.
     

Products Discussed in

To Top