1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2 Questions/Problems

Discussion in '3rd Gen 4Runners (1996-2002)' started by UssMoGn, Jul 11, 2015.

  1. Jul 11, 2015 at 11:29 PM
    #1
    UssMoGn

    UssMoGn [OP] That Vegas Dude

    Joined:
    Apr 9, 2015
    Member:
    #558
    Messages:
    425
    Gender:
    Male
    First Name:
    James
    Vehicle:
    1996 TaCoRunner
    Extented Coil Lift. Custom bumpers
    So my Trucks going on 204K+ miles. So stuffs warn out and beat up. A LOT of it is still factory Parts. Im pretty damn good at working on stuff but ive been chasing these problems for a while with no progress. Maybe another set of ideas might be better.

    Problem #1
    ABS Lights is stuck on. Will occasionally be off when I get in the truck but comes on shortly after moving.
    -Check all connectos
    -Cleaned and checked all sensors
    -Fluids are good
    -ABS still works on bumpy stops

    Problem #2
    Soft Brakes, Brakes stop but see to be weak. Almost like the booster is not helping or something not grabbing. Seem to happen when I pulled the motor and had it rebuilt and put it back in.
    - Vaccum lines have been checked
    - NEW master brake cylender
    - USED Brake Booster swap(Cant imagine I got a broken Salvaged BB)
    - USED ABS actuator swap
    - Flushed lines and used entire system bleeder machine
    - No leaks anywhere
    - Pads seem not to grab in the front. They look almost new with bunch of miles on them
    - Truck pulls to one side a little at high speed braking

    None of these issues Throw any type of codes.

    Any help or ideas would be awesome.
     
  2. Nov 21, 2015 at 8:17 PM
    #2
    Krawler

    Krawler New Member

    Joined:
    Nov 1, 2015
    Member:
    #1123
    Messages:
    18
    Gender:
    Male
    Vehicle:
    96 4Runner
    Maybe it is just goodbye brakes. Could try to get a new rotor.
     
  3. Jan 20, 2016 at 6:09 PM
    #3
    The.Giff

    The.Giff New Member

    Joined:
    Jan 17, 2016
    Member:
    #1423
    Messages:
    18
    Gender:
    Male
    First Name:
    Chris
    Check your Brake booster. I have seen many times that the master cylinder will leak Brake fluid into the Booster though the master cylinder itself, You wont see any fluid externally but if you take the vacuum connection off and stick a towel or chain inside you might see your problem. There shouldn't be any fluid inside there.
     

Products Discussed in

To Top