1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

1993 Toyota 4runner v6 3.0 multiple codes...

Discussion in '2nd Gen 4Runners (1990-1995)' started by Bretgreen, Sep 20, 2018.

  1. Sep 20, 2018 at 6:30 PM
    #1
    Bretgreen

    Bretgreen [OP] New Member

    Joined:
    Sep 20, 2018
    Member:
    #7219
    Messages:
    1
    Gender:
    Male
    Vehicle:
    1993 Toyota 4runner v6 3.0 2nd gen.
    Stock
    I have a 1993 Toyota 4runner v6 3.0 2nd generation. It idles high at 1000 and when I put it in drive or reverse it stalls out. In idle the radiator over flow will blow steam within minutes but it won't over heat. Thermostat is good and no catalytic converter. Had to cut it out last night because it was clogged. Was told that would help but it has made no changes. The codes are
    14, ignition reference signal no signal.
    22 engine coolant temp sensor circuit.
    24 intake air temp sensor.
    25 mixture control constantly lean.
    31 volume air flow sensor.
    I have no idea where to go from here. Any help is greatly appreciated.
     
  2. Oct 10, 2018 at 9:07 PM
    #2
    Dink

    Dink New Member

    Joined:
    Aug 18, 2018
    Member:
    #6799
    Messages:
    9
    Gender:
    Male
    First Name:
    Chris
    Vehicle:
    1993 4Runner SR5
    Stock with roof rack
    Could be a few things. Have you block tested it to make sure there isn't a blown headgasket? Recently had a timing belt done? TPS sensors were known to fail..
     

Products Discussed in

To Top