1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

1987 4runner sputtering/jerking

Discussion in 'General 4Runner Talk' started by thedingo5, Aug 16, 2019.

  1. Aug 16, 2019 at 2:03 AM
    #1
    thedingo5

    thedingo5 [OP] New Member

    Joined:
    Aug 16, 2019
    Member:
    #10909
    Messages:
    2
    Gender:
    Male
    First Name:
    austin
    my 87 4runner started having a light sputtering problem that turned into me now not being able to drive it. at idle its fine but when i start to drive it down the road at about 2500 it starts sputtering and jerking with no power. i have replaced the plugs they were black nasty like its running rich. also new cap and rotor. i have a check light that comes on for a few goes back off for about 5 mins. also my front 02 sensor wire is a bit fucked.. maybe that is my problem? i need help before i keep spending money on it.
     
  2. Aug 16, 2019 at 6:07 AM
    #2
    SlvrSlug

    SlvrSlug New Member

    Joined:
    Jun 3, 2018
    Member:
    #6172
    Messages:
    972
    Gender:
    Male
    First Name:
    John
    San Diego, Ca.
    Vehicle:
    2017 4-Runner SR-5
    Slightly modded
    Welcome.
     
  3. Aug 16, 2019 at 12:18 PM
    #3
    Dark Knight

    Dark Knight Get off my lawn

    Joined:
    Sep 18, 2016
    Member:
    #2681
    Messages:
    538
    Gender:
    Male
    First Name:
    Jeff
    Start with the O2 sensor. Sometimes it’s a trial and error process.
     
  4. Aug 16, 2019 at 2:02 PM
    #4
    yotagreg8888

    yotagreg8888 New Member

    Joined:
    May 4, 2019
    Member:
    #9756
    Messages:
    14
    Gender:
    Male
    First Name:
    Greg
    Vehicle:
    1985 SR5
    OME lift other wise 100 percent stock
    Welcome - Could be the Igniter, That's the little black box on top of the coil and if it is bad, it's most likely the pick up in the distributor that's frying it. I went through 2 used igniters to learn this. Replaced both distributor and igniter with new OEM parts for $850 in my 85.
     
  5. Aug 16, 2019 at 2:37 PM
    #5
    yotagreg8888

    yotagreg8888 New Member

    Joined:
    May 4, 2019
    Member:
    #9756
    Messages:
    14
    Gender:
    Male
    First Name:
    Greg
    Vehicle:
    1985 SR5
    OME lift other wise 100 percent stock
    Also, when an O2 sensor goes bad the only thing that happens is your mileage goes to hell, it does not really change the way the car runs.
     
  6. Aug 16, 2019 at 2:52 PM
    #6
    Thatbassguy

    Thatbassguy New Member

    Joined:
    Mar 27, 2019
    Member:
    #9314
    Messages:
    370
    Gender:
    Male
    First Name:
    James
    S/E Wisconsin
    Vehicle:
    2019 TRDORP, KDSS, MGM
    RSG sliders, Yakima offgrid basket, Pro-Comp wheels
    Check your intake tubing.

    My brother had an '87 Corolla that somehow got a crack in the air intake tubing. It would jerk and sputter under acceleration, due to the mass air sensor giving a bad reading.

    And, welcome to the forum!
     
  7. Aug 16, 2019 at 5:43 PM
    #7
    4x Old Guy

    4x Old Guy New Member

    Joined:
    Aug 2, 2019
    Member:
    #10764
    Messages:
    24
    Gender:
    Male
    Riverside, CA
    Vehicle:
    2019 Silver TRD Off-road Premium
    Big-O Bigfoot A/T tires
    Find someone who has on OBD-2 code reader. The truck may be able to tell you what’s wrong with it. Some auto parts stores will check the codes for you (assuming you’ll buy the parts from them).
     
    Thatbassguy likes this.
  8. Aug 16, 2019 at 6:01 PM
    #8
    Limu

    Limu New Member

    Joined:
    Jul 23, 2018
    Member:
    #6515
    Messages:
    11
    Gender:
    Male
    Fuel filter.
     
    Thatbassguy likes this.
  9. Aug 16, 2019 at 10:03 PM
    #9
    thedingo5

    thedingo5 [OP] New Member

    Joined:
    Aug 16, 2019
    Member:
    #10909
    Messages:
    2
    Gender:
    Male
    First Name:
    austin
    thanks everyone, got a new 02 in it today started running better i guess it was in a limp mode. but ran into another problem my throttle position sensor was a little lose i replaced it not to long ago the guy before me didn't have the right bolts in it so ill be finding some tomorrow to tighten that up. I'm going to go ahead a get a new fuel filter because I'm at about 178000 miles and have no idea if the guy before me ever changed it. ill up date after and see if my problems have gone away. I'm still going to look into all the other things everyone has suggested because it docent seem he took every good care it. can't hurt to look thanks again for all the help everyone.
     
    Thatbassguy likes this.

Products Discussed in

To Top