1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

P0430 after misfire bad coil

Discussion in '4th Gen 4Runners (2003-2009)' started by buddy75, Jun 18, 2024.

  1. Jun 18, 2024 at 9:05 AM
    #1
    buddy75

    buddy75 [OP] New Member

    Joined:
    Jun 18, 2024
    Member:
    #41132
    Messages:
    1
    Gender:
    Male
    First Name:
    Jason
    Vehicle:
    2005 4Runner V6 Sport 4WD
    Hello: first timer here. I had a bad coil in cylinder 6 misfire. Drove it only a short (1/2) mile back home. Check engine light came on with P0430 code. I replaced coil and spark plugs. Light never went off. Used a bottle of cat cleaner and it still stayed on. Replaced downstream O2 sensor and that seemed to do the trick. However, about a month of driving it it came back on again. I haven’t taken it to a mechanic and my skill set is probably not sophisticated enough to replace CAT. Should I replace upstream O2 sensor and see if that works? I’m concerned it is the CAT but I don’t want to spend that kind of money on this vehicle that has 215k miles. Any help would be appreciated. Thank you!!
     
  2. Jun 18, 2024 at 12:21 PM
    #2
    RonT4R

    RonT4R New Member

    Joined:
    Mar 24, 2015
    Member:
    #526
    Messages:
    614
    Gender:
    Male
    First Name:
    Ron
    Virginia Beach
    Vehicle:
    2007 4runner SR5 4WD
    Fuel injector was my misfire problem not the coil pack.
     

Products Discussed in

To Top