1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

help with fuel issue

Discussion in '4th Gen 4Runners (2003-2009)' started by goguendo, Jul 11, 2022.

  1. Jul 11, 2022 at 10:44 AM
    #1
    goguendo

    goguendo [OP] New Member

    Joined:
    Jun 5, 2022
    Member:
    #27331
    Messages:
    5
    Gender:
    Male
    First Name:
    andre goguen
    Vehicle:
    05 4runner sr5 beater
    i wondered if anyone has had the issue im experiencing with my 05 4runner.......it runs fine but when theres somewhere around a 1/4 tank of fuel left, itll start cutting out and losing power on the highway....ive had it happen twice where the range says theres about 90miles......then....once i fill up, the problem goes away....i am sure its not just an accuracy issue because the car will only take about 14 gallons.....i started thinking it was related to the fuel pump then thought maybe the evap system.........but i sure could use help from someone who has had a similar problem.......thanks in advance
     
  2. Jul 11, 2022 at 11:16 AM
    #2
    golfguy

    golfguy New Member

    Joined:
    Feb 17, 2018
    Member:
    #5502
    Messages:
    307
    Gender:
    Male
    First Name:
    Jay
    W. TN
    Vehicle:
    2018 TRD ORP, 2007 SR5 4WD
    Sounds like you may have a problem with the sending unit. I had something similar happen in my 4th gen a couple of years ago. I ran a couple bottles of Techron thru it which apparently cleaned up the gunk that was affecting the resistor. However if that doesn’t fix it, then the fuel pump and sending unit will more than likely need to be replaced.
     
  3. Jul 12, 2022 at 4:11 PM
    #3
    negusm

    negusm New Member

    Joined:
    Oct 22, 2019
    Member:
    #11745
    Messages:
    1,243
    Gender:
    Male
    Vehicle:
    2002 4Runner SR5 4WD
    May be the fuel pump. When the fuel level gets low, the pump now has no fuel to cool it. When you fill it up, it works fine. If you replace the pump...and if the tank needs to be dropped...replace the sending unit...should be no extra labor. Replace all seals for everything else on the tank too.
     
  4. Jul 13, 2022 at 2:48 PM
    #4
    goguendo

    goguendo [OP] New Member

    Joined:
    Jun 5, 2022
    Member:
    #27331
    Messages:
    5
    Gender:
    Male
    First Name:
    andre goguen
    Vehicle:
    05 4runner sr5 beater
    thanks man..thought that may be the case
     

Products Discussed in

To Top