1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

HELP! Hesitation on acceleration

Discussion in '4th Gen 4Runners (2003-2009)' started by KeepsBreakingThings, Aug 9, 2018 at 9:18 AM.

  1. Aug 9, 2018 at 9:18 AM
    #1
    KeepsBreakingThings

    KeepsBreakingThings [OP] New Member

    Joined:
    Thursday
    Member:
    #6675
    Messages:
    2
    Vehicle:
    2006 4Runner Limited
    Problem:
    Step on the gas pedal and it feels like the truck falls on its face before taking off. There is a hesitation of about 1 second before the engine kicks in and the truck goes. I can step on the pedal lightly to get past this hesitation before going but the hesitation is still there, just not felt as much. The lag happens in park and neutral as well as in gear (Automatic Transmission). I have done a few things myself based on other threads as well as taking it to the dealer with no solution. There are no codes coming up on the computer. Other threads have become too cluttered, hoping a new one can help identify root cause and solution.

    What I've done:
    Changed plugs, ignition coils, MAF sensor
    Cleaned K&N air filter
    Fuel system cleaner and ran through whole tank of gas to empty
    Dealership comments:
    Fuel is good
    Fuel pressure is good
    Cats are functioning as they should.

    Please help...
     
  2. Aug 11, 2018 at 9:45 PM
    #2
    themixr

    themixr New Member

    Joined:
    May 19, 2018
    Member:
    #6059
    Messages:
    16
    Gender:
    Male
    First Name:
    Tony
    Vehicle:
    06 4Runner
    Clean your mass airflow censor.
     
  3. Aug 13, 2018 at 5:11 AM
    #3
    KeepsBreakingThings

    KeepsBreakingThings [OP] New Member

    Joined:
    Thursday
    Member:
    #6675
    Messages:
    2
    Vehicle:
    2006 4Runner Limited
    I have already changed MAF sensor.
     

Products Discussed in

To Top