1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Electrical issues

Discussion in '3rd Gen 4Runners (1996-2002)' started by Crich1, Apr 2, 2024.

  1. Apr 2, 2024 at 11:39 AM
    #1
    Crich1

    Crich1 [OP] New Member

    Joined:
    Apr 2, 2024
    Member:
    #39549
    Messages:
    3
    Touch screen radio
    Hello all, I'm new to the forum and in desperate need of help. I have a 97 4runner with a weird electrical issue, nothing on the instrument panel works or the windows, radio and the car will start but will not stay on. It looks like what ever system is down might also control the alternator so it will run until the battery is out of juice.

    I thought maybe the ecu because the wires in the harness leading from the ecu to the air flow meter had a 4 inch section of bare copper showing and the connector for the engine temperature sensor was melted and wires were burnt. I replaced the bad wires and sensor and the fuses for the ecu were still good but I'm still having the same issue.

    I'm looking through the wiring diagrams but still not sure what I'm looking for. Has anyone seen this before?
     
  2. Apr 2, 2024 at 7:03 PM
    #2
    Trekker

    Trekker Regular Member

    Joined:
    Jul 25, 2020
    Member:
    #15732
    Messages:
    903
    Gender:
    Male
    Vehicle:
    1997 3rz 5spd
    Never seen this. Check the ground points, they can cause strange issues. Why was the wire stripped bare and the engine temp sensor melted in the first place? Are there any electrical mods on the vehicle?
     
  3. Apr 2, 2024 at 10:39 PM
    #3
    Crich1

    Crich1 [OP] New Member

    Joined:
    Apr 2, 2024
    Member:
    #39549
    Messages:
    3
    Touch screen radio
    Will definitely start checking that, it most likely started when the starter went bad and the solenoid was stuck open, the battery was destroyed so I replaced it and the starter plus the connectors for the battery and it worked fine for a few months until this happened.

    I forgot to add I also cannot shift out of park
     
  4. Apr 3, 2024 at 2:44 PM
    #4
    Trekker

    Trekker Regular Member

    Joined:
    Jul 25, 2020
    Member:
    #15732
    Messages:
    903
    Gender:
    Male
    Vehicle:
    1997 3rz 5spd
    Is the gear lever itself stuck or is it something electronic? There is an override that you can do to make it change gears.

    It sounds like it got pretty bad, I'd be a little concerned about the computers if it managed to damage so many other things. But let's not make assumptions.

    Have you scanned for codes?
     
  5. Apr 4, 2024 at 10:07 AM
    #5
    Crich1

    Crich1 [OP] New Member

    Joined:
    Apr 2, 2024
    Member:
    #39549
    Messages:
    3
    Touch screen radio
    I can't get any codes to show up
     
  6. Apr 4, 2024 at 12:34 PM
    #6
    Trekker

    Trekker Regular Member

    Joined:
    Jul 25, 2020
    Member:
    #15732
    Messages:
    903
    Gender:
    Male
    Vehicle:
    1997 3rz 5spd
    Is it not getting codes because there are none or do you suspect the scanner isn't connecting with the computer? If you're not sure, unplug the maf and try starting it a few times (it wont run without it), that should produce codes and if nothing shows up that's not good.

    I'd recommend going on the toyota-4runner .org forum with this problem because it's better for 3rd gen issues, and there are more people on it. Revive an old thread about a similar topic because you can't start a new thread the moment you sign up.
     

Products Discussed in

To Top