1. Welcome to 4Runners.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all 4Runner discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other 4Runner owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2023 Headunit Restarting Randomly in CarPlay

Discussion in '5th Gen 4Runners (2010-2024)' started by satoshi, Aug 12, 2023.

  1. Aug 12, 2023 at 9:40 AM
    #1
    satoshi

    satoshi [OP] Mοderatοr

    Joined:
    Aug 2, 2023
    Member:
    #34558
    Messages:
    86
    Gender:
    Male
    Vehicle:
    2023 TRD ORP LUNAR ROCK
    Anyone else having issues with their headunit going black and "Restarting..." during carplay? It usually happens to me about 30 - 120 seconds after starting the vehicle.

    I have an iPhone 14 Pro Max on iOS 16.6. It will connect to CarPlay just fine but then the headunit will reboot. After it reboots once, it seems stable for the rest of the drive. I would say it happens about 60% of the time I start the car.

    I have confirmed I am on the latest software and there are no upgrades available from Toyota.

    I am using a wireless carplay adapter so I'm not 100% sure if that is the issue yet or not. Will do more testing on a long road trip I have coming up.

    This issue seems to be pretty common so far, I've found a few resources that discuss the same issue:

    - https://www.rav4world.com/threads/infotainment-keeps-rebooting-randomly.328325/
    - https://www.reddit.com/r/rav4club/c...ainment_system_restarts_apple_car_play_every/

    Replies indicate this issue seems to have started in iOS 16.4 or 16.5.
     
  2. Aug 12, 2023 at 3:43 PM
    #2
    Steely123

    Steely123 What's the new trend? I'll do it!

    Joined:
    Jun 4, 2022
    Member:
    #27323
    Messages:
    2,070
    Gender:
    Male
    Georgetown, TX
    Vehicle:
    2018 4runner SR5 premium
    I also have IP14 pro max 16.6. My alpine halo9 with built in car play well go black during a call. Wireless or wired. Can't do anything until the truck. is turned off. It's ios 16.4+. Not car play on your radio.
     
  3. Aug 12, 2023 at 5:15 PM
    #3
    satoshi

    satoshi [OP] Mοderatοr

    Joined:
    Aug 2, 2023
    Member:
    #34558
    Messages:
    86
    Gender:
    Male
    Vehicle:
    2023 TRD ORP LUNAR ROCK
    That's good to hear that it's probably not the OEM headunit, would hate to have to deal with warranty on it when I'm not even at 1,000 miles. Sucks about Carplay, really hope apple fixes it soon.

    It's nerve-wracking to see the head unit go completely black. Most of the time it says "restarting..." but sometimes it's stayed black for 30+ seconds which always makes me nervous on a new car.
     
    Steely123[QUOTED] likes this.
  4. Aug 12, 2023 at 5:29 PM
    #4
    Steely123

    Steely123 What's the new trend? I'll do it!

    Joined:
    Jun 4, 2022
    Member:
    #27323
    Messages:
    2,070
    Gender:
    Male
    Georgetown, TX
    Vehicle:
    2018 4runner SR5 premium
    Yeah the first time i was driving down the highway and was like "seriously?!" Lol
     
    satoshi[QUOTED][OP] likes this.

Products Discussed in

To Top